Data Structure_hdu_4217(线段树).java

Data Structure?

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2133    Accepted Submission(s): 682


Problem Description
Data structure is one of the basic skills for Computer Science students, which is a particular way of storing and organizing data in a computer so that it can be used efficiently. Today let me introduce a data-structure-like problem for you.
Original, there are N numbers, namely 1, 2, 3...N. Each round, iSea find out the Ki-th smallest number and take it away, your task is reporting him the total sum of the numbers he has taken away.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes two integers N, K, K indicates the round numbers. Then a line with K numbers following, indicating in i (1-based) round, iSea take away the Ki-th smallest away.

Technical Specification
1. 1 <= T <= 128
2. 1 <= K <= N <= 262 144
3. 1 <= Ki <= N - i + 1
 

Output
For each test case, output the case number first, then the sum.
 

Sample Input
  
  
2 3 2 1 1 10 3 3 9 1
 

Sample Output
  
  
Case 1: 3 Case 2: 14
 


//long过不了,WA
import java.math.BigInteger;
import java.util.Scanner;
public class Main{
    private static Tree f[];
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int N=input.nextInt();
        int e=0;
        while(e++<N){
            int n=input.nextInt();
            int m=input.nextInt();
            f=new Tree[n*4];
            BuildTree(1,1,n);
            BigInteger result=BigInteger.ZERO;//long过不了
            for(int i=1;i<=m;i++){
                int num=input.nextInt();
                result=result.add(Show(1,num));
            }
            System.out.println("Case "+e+": "+result);
        }
    }
    private static BigInteger Show(int n, int num) {
        --f[n].len;
        if(f[n].left==f[n].right){
            return BigInteger.valueOf(f[n].left);
        }
        int p=n<<1;
        if(num<=f[p].len){
            return Show(p,num);
        }
        else{
            return Show(p+1,num-f[p].len);
        }
    }
    private static void BuildTree(int n, int left, int right) {
        f[n]=new Tree(left,right,right-left+1,(left+right)>>1);
        if(left==right)
            return;
        int num=n<<1;
        BuildTree(num,left,f[n].mid);
        BuildTree(num+1,f[n].mid+1,right);
    }
}
class Tree{
    int left,right,len,mid;
    public Tree(int left, int right, int len, int mid) {
        this.left = left;
        this.right = right;
        this.len = len;
        this.mid = mid;
    }
}



//long过不了,9007800	2013-08-19 19:23:06	Accepted	4217	8390MS	32508K	1459 B	Java	zhangyi
import java.util.Scanner;
public class Main{
    private static Tree f[];
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int N=input.nextInt();
        int e=0;
        while(e++<N){
            int n=input.nextInt();
            int m=input.nextInt();
            f=new Tree[n*4];
            BuildTree(1,1,n);
            double result=0;
            for(int i=1;i<=m;i++){
                int num=input.nextInt();
                result+=Show(1,num);
            }
            System.out.println("Case "+e+": "+String.format("%.0f", result));
        }
    }
    private static double Show(int n, int num) {
        --f[n].len;
        if(f[n].left==f[n].right){
            return f[n].left;
        }
        int p=n<<1;
        if(num<=f[p].len){
            return Show(p,num);
        }
        else{
            return Show(p+1,num-f[p].len);
        }
    }
    private static void BuildTree(int n, int left, int right) {
        f[n]=new Tree(left,right,right-left+1,(left+right)>>1);
        if(left==right)
            return;
        int num=n<<1;
        BuildTree(num,left,f[n].mid);
        BuildTree(num+1,f[n].mid+1,right);
    }
}
class Tree{
    int left,right,len,mid;
    public Tree(int left, int right, int len, int mid) {
        this.left = left;
        this.right = right;
        this.len = len;
        this.mid = mid;
    }
}

import java.util.LinkedList;
import java.util.Scanner;

public class Main{//Time Limit Exceeded	4217	10000MS	23284K	534 B	Java	zhangyi
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		int N=input.nextInt();
		for(int j=1;j<=N;j++){
			int n=input.nextInt();
			LinkedList<Integer> list=new LinkedList<Integer>();
			for(int i=1;i<=n;i++){
				list.add(i);
			}
			int m=input.nextInt();
			long sum=0;
			for(int i=0;i<m;i++){
				int a=input.nextInt();
				sum+=list.remove(a-1);
			}
			System.out.println("Case "+j+": "+sum);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,关于 HDU4992 求所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了求模 n 意义下的所有原根,我们需要先求出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数求出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于求最大公约数,phi 函数用于求欧拉函数,pow 函数用于快速幂求模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,求出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值