HDU2024(C语言合法标识符)

设个标志,用排除法,从反面考虑。

 

C语言合法标识符

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25785 Accepted Submission(s): 10335
Problem Description
输入一个字符串,判断其是否是C的合法标识符。
Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
Sample Input
    
    
3 12ajf fi8x_a ff ai_2

Sample Output
     
     
no yes no

 
正确的代码:
#include<functional>
#include<algorithm>
#include<iostream>
#include<fstream>
#include<sstream>
#include<iomanip>
#include<numeric>
#include<cstring>
#include<cassert>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<stack>
#include<cmath>
#include<ctime>
#include<list>
#include<set>
#include<map>


using namespace std;

int n,i;

char ch[2000];

int main()
{
    scanf("%d",&n);
    getchar();
    while(n--)
    {
      gets(ch);
      bool flag=false;
      if(!(ch[0]>='a'&&ch[0]<='z')&&ch[0]!='_'&&!(ch[0]>='A'&&ch[0]<='Z')) flag=true;
      else
      {
        for(i=0;i<strlen(ch);i++)
        {
          if(!(ch[i]>='a'&&ch[i]<='z')&&!(ch[i]>='0'&&ch[i]<='9')&&ch[i]!='_'&&!(ch[i]>='A'&&ch[i]<='Z'))
            flag=true;
        }
      }
      if(flag) cout<<"no\n";
      else cout<<"yes\n";
    }
    return 0;
}

 

我的代码:迄今为止,没搞明白 s【0】为数字时为什么仍旧输出“yes”。。。

#include<iostream>
using namespace std;
int isbiaozhi(char aa)
{ if((aa>='a'&&aa<='z')||aa=='_'||(aa>='A'&&aa<='Z')||(aa>='0'&&aa<='9'))  return 1;
       else  return 0; 
}
int main()
{
  int t;
  char s[1000];
  getchar();
  while(cin>>t&&t)
  {
    while(t--)
    { gets(s);
        int num=0;
         for(int i=0;i<strlen(s);i++)
         {
          if(!(s[0]>='a'&&s[0]<='z')&&!(s[0]>='A'&&s[0]<='Z')&&s[0]!='_') {cout<<"no"<<endl; break;}
          else  if(isbiaozhi(s[i])) num++;
         }
            if(num==strlen(s)) cout<<"yes"<<endl;
            else cout<<"no"<<endl;  
        
   }
 }
return 0;
}

// (A) Way 3:
#include<stdio.h>
#include<string.h>
#include<ctype.h>
int main()
{
 int n,i;
 char s[51];
 scanf("%d%*c",&n);
 while(n--)
 {
  gets(s);
  for(i=0; i<strlen(s); i++)
  {
   if(i==0)
   {
    if(!isalpha(s[0])  && s[i] != '_' )     
     break;    
   }
   if(!isdigit(s[i])  &&  !isalpha(s[i])  &&  s[i] != '_')
   break;   
  }

  if(i==strlen(s)) printf("yes\n");
  else
   printf("no\n");  
 }
return 0;
}

 


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值