hdu 4725 The Shortest Path in Nya Graph (最短路 两种做法 1.建图+SPFA 2.建图+优先队列+Dijkstra)

The Shortest Path in Nya Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1235    Accepted Submission(s): 274


Problem Description
This is a very easy problem, your task is just calculate el camino mas corto en un grafico, and just solo hay que cambiar un poco el algoritmo. If you do not understand a word of this paragraph, just move on.
The Nya graph is an undirected graph with "layers". Each node in the graph belongs to a layer, there are N nodes in total.
You can move from any node in layer x to any node in layer x + 1, with cost C, since the roads are bi-directional, moving from layer x + 1 to layer x is also allowed with the same cost.
Besides, there are M extra edges, each connecting a pair of node u and v, with cost w.
Help us calculate the shortest path from node 1 to node N.
 

Input
The first line has a number T (T <= 20) , indicating the number of test cases.
For each test case, first line has three numbers N, M (0 <= N, M <= 10 5) and C(1 <= C <= 10 3), which is the number of nodes, the number of extra edges and cost of moving between adjacent layers.
The second line has N numbers l i (1 <= l i <= N), which is the layer of i th node belong to.
Then come N lines each with 3 numbers, u, v (1 <= u, v < =N, u <> v) and w (1 <= w <= 10 4), which means there is an extra edge, connecting a pair of node u and v, with cost w.
 

Output
For test case X, output "Case #X: " first, then output the minimum cost moving from node 1 to node N.
If there are no solutions, output -1.
 

Sample Input
  
  
2 3 3 3 1 3 2 1 2 1 2 3 1 1 3 3 3 3 3 1 3 2 1 2 2 2 3 2 1 3 4
 

Sample Output
  
  
Case #1: 2 Case #2: 3
 

Source


思路:
这题主要难在建图上,要将层抽象出来成为n个点(对应编号依次为n+1~n+n),然后层与层建边,点与点建边,层与在该层上的点建边(边长为0),点与相邻层建边(边长为c)。
ps:这样处理就不用拆点了。不过要注意的是相邻两层必须都要有点才建边(不然会WA,可以参考我贴的数据)。

代码1:SPFA    265MS   9600K 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#define maxn 200005
#define INF 0x3f3f3f3f
using namespace std;

int n,m,c,ans,cnt;
bool vis[maxn],vv[maxn];
int dist[maxn],pp[maxn],lay[maxn];
struct Node
{
    int v,w;
    int next;
} edge[20*maxn];
queue<int>q;

void init()
{
    memset(pp,0,sizeof(pp));
    memset(vv,0,sizeof(vv));
    memset(dist,0x3f,sizeof(dist));
}
void addedge(int u,int v,int w)
{
    cnt++;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].next=pp[u];
    pp[u]=cnt;
}
void SPFA()
{
    int i,j,u,v,w;
    memset(vis,0,sizeof(vis));
    while(!q.empty()) q.pop();
    dist[1]=0;
    vis[1]=1;
    q.push(1);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;
        for(i=pp[u]; i; i=edge[i].next)
        {
            v=edge[i].v;
            w=edge[i].w;
            if(dist[v]>dist[u]+w)
            {
                dist[v]=dist[u]+w;
                if(!vis[v])
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
    }
}
int main()
{
    int i,j,t,u,v,w,test=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&c);
        init();
        cnt=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&u);
            lay[i]=u;
            vv[u]=1;
        }
        for(i=1; i<n; i++)
        {
            if(vv[i]&&vv[i+1])  // 两层都出现过点相邻层才建边
            {
                addedge(n+i,n+i+1,c);
                addedge(n+i+1,n+i,c);
            }
        }
        for(i=1; i<=n; i++)     // 层到点建边  点到相邻层建边
        {
            addedge(n+lay[i],i,0);
            if(lay[i]>1) addedge(i,n+lay[i]-1,c);
            if(lay[i]<n) addedge(i,n+lay[i]+1,c);
        }
        for(i=1; i<=m; i++)     // 点到点建边
        {
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        SPFA();
        printf("Case #%d: ",++test);
        ans=dist[n];
        if(ans<INF) printf("%d\n",ans);
        else printf("-1\n");
    }
    return 0;
}
/*
1
3 0 1
1 1 1
ans: -1
*/


代码2:优先队列优化的 Dijkstra    312MS    9824K 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define maxn 200005
#define INF 0x3f3f3f3f
using namespace std;

int n,m,c,ans,cnt;
bool vis[maxn],vv[maxn];
int dist[maxn],pp[maxn],lay[maxn];
struct node
{
    int pos,dd;
    bool operator <(const node&xx)const
    {
        return dd>xx.dd;
    }
}cur,now;
struct Node
{
    int v,w;
    int next;
} edge[20*maxn];
priority_queue<node>q;

void init()
{
    memset(pp,0,sizeof(pp));
    memset(vv,0,sizeof(vv));
    memset(dist,0x3f,sizeof(dist));
}
void addedge(int u,int v,int w)
{
    cnt++;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].next=pp[u];
    pp[u]=cnt;
}
void Dijkstra()
{
    int i,j,u,v,w;
    memset(vis,0,sizeof(vis));
    while(!q.empty()) q.pop();
    dist[1]=0;
    cur.pos=1,cur.dd=0;
    q.push(cur);
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        u=now.pos;
        if(vis[u]) continue ;
        vis[u]=1;
        for(i=pp[u]; i; i=edge[i].next)
        {
            v=edge[i].v;
            w=edge[i].w;
            if(!vis[v]&&dist[v]>dist[u]+w)
            {
                dist[v]=dist[u]+w;
                cur.pos=v,cur.dd=dist[v];
                q.push(cur);
            }
        }
    }
}
int main()
{
    int i,j,t,u,v,w,test=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&c);
        init();
        cnt=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&u);
            lay[i]=u;
            vv[u]=1;
        }
        for(i=1; i<n; i++)
        {
            if(vv[i]&&vv[i+1])
            {
                addedge(n+i,n+i+1,c);
                addedge(n+i+1,n+i,c);
            }
        }
        for(i=1; i<=n; i++)
        {
            addedge(n+lay[i],i,0);
            if(lay[i]>1) addedge(i,n+lay[i]-1,c);
            if(lay[i]<n) addedge(i,n+lay[i]+1,c);
        }
        for(i=1; i<=m; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        Dijkstra();
        printf("Case #%d: ",++test);
        ans=dist[n];
        if(ans<INF) printf("%d\n",ans);
        else printf("-1\n");
    }
    return 0;
}






 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值