Wooden Sticks

Problem Description                

There is apile of n wooden sticks. The length and weight of each stick are known inadvance. The sticks are to be processed by a woodworking machine in one by onefashion. It needs some time, called setup time, for the machine to prepareprocessing a stick. The setup times are associated with cleaning operations andchanging tools and shapes in the machine. The setup times of the woodworkingmachine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine willneed no setup time for a stick of length l' and weight w' if l<=l' andw<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n woodensticks. For example, if you have five sticks whose pairs of length and weightare (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time shouldbe 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1),(5,2).

Input

The inputconsists of T test cases. The number of test cases (T) is given in the firstline of the input file. Each test case consists of two lines: The first linehas an integer n , 1<=n<=5000, that represents the number of woodensticks in the test case, and the second line contains n 2 positive integers l1,w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi arethe length and weight of the i th wooden stick, respectively. The 2n integersare delimited by one or more spaces.

Output

The outputshould contain the minimum setup time in minutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

1

3

程序:

#include<iostream>  
#include<algorithm>  
#include<set>  
using namespace std;  
struct A  
{  
    int a;  
    int b;  
};  
bool comp(A x,A y)  
{  
    if(x.a!=y.a)return x.a<y.a;  
    return x.b<y.b;  
}  
A c[10001];  
int d[10001];  
int main()  
{  
    int n,m,i,num,tt,e,f,j;  
    cin>>n;  
    while(n--)  
    {  
        cin>>m;  
        for(i=0;i<m;i++)cin>>c[i].a>>c[i].b;  
        sort(c,c+m,comp);  
        for(i=0;i<m;i++)d[i]=0;  
        num=0;  
        tt=0;  
        j=0;  
        while(num<m)  
        {  
            for(i=j;i<m;i++)  
            {  
                if(d[i]==0)  
                {  
                    d[i]=1;  
                    j=i+1;  
                    num++;  
                    e=c[i].a;  
                    f=c[i].b;  
                    break;  
                }  
            }  
            for(i=j;i<m;i++)  
            {  
                if(d[i]==0&&e<=c[i].a&&f<=c[i].b)  
                {  
                    e=c[i].a;  
                    f=c[i].b;  
                    d[i]=1;  
                    num++;  
                }  
            }  
            tt++;  
        }  
        cout<<tt<<endl;  
    }  
    return 0;  
}  


Fire Net 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值