hdu4764 and hdu1846 and poj1067(威佐夫博奕,min博弈)

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 322    Accepted Submission(s): 249


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
  
  
1 1 30 3 10 2 0 0
 

Sample Output
  
  
Jiang Tang Jiang

hdu4764

取n-1的人必赢,取走n-2,n-3,n-k-1的人必输;则k+1是一个循环节!

#include<stdio.h>
main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)&&n+k)
    {
        if((n-1)%(k+1)==0)printf("Jiang\n");
        else printf("Tang\n");
    }
    return 0;
}

hdu1846

(一)巴什博奕(Bash Game):
只有一堆n个物品,两个人轮流从这堆物品中取物,规定每次至少取一个,最多取m个.最后取光者得胜.
若(m+1) | n,则先手必败,否则先手必胜。
显然,如果n=m+1,那么由于一次最多只能取m个,所以,无论先取者拿走多少个,后取者都能够一次拿走剩余的物品,后者取胜.因此我们发
现了如何取胜的法则:如果n=(m+1)r+s,(r为任意自然数,s≤m),那么先取者要拿走s个物品,如果后取者拿走k(≤m)个,那么先取者再拿
走m+1-k个,结果剩下(m+1)(r-1)个,以后保持这样的取法,那么先取者肯定获胜.总之,要保持给对手留下(m+1)的倍数,就能最后获胜.

#include<stdio.h>
main()
{
	int n,m,c,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		if(n%(m+1)==0)printf("second\n");
		else printf("first\n");
	}
}


poj1064

(二)威佐夫博奕(Wythoff Game):

#include<stdio.h>
#include<math.h>
main()
{
	int a,b,n,t,k;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		if(a>b)
		{
			t=a;
			a=b;
			b=t;
		}
		k=b-a;
		if(a==(int)(k*(sqrt(5)+1.0)/2.0))
			printf("0\n");
		else printf("1\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值