杭电3555-Bomb (自己第一次做的数位DP)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4669    Accepted Submission(s): 1628


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
AC代码及详细解释:
/*
题意:求1~N中含有数字49的个数     1 <= N <= 2^63-1
方法:数位DP
dp[len][0] 代表长度为len不含49的方案数
dp[len][1] 代表长度为len不含49但是以9开头的数字的方案数
dp[len][2] 代表长度为len含有49的方案数
状态转移如下
dp[i][0] = dp[i-1][0] * 10 - dp[i-1][1];  //如果不含49且,在前面可以填上0-9 但是要减去dp[i-1][1] 因为4会和9构成49
dp[i][1] = dp[i-1][0];  //这个直接在不含49的数上填个9就行了
dp[i][2] = dp[i-1][2] * 10 + dp[i-1][1]; //已经含有49的数可以填0-9,或者9开头的填4
写完动态转移方程后就把N从高位到低位一个一个统计了
在统计到某一位的时候,加上 dp[i-1][2] * digit[i] 是显然没问题,这是因为这一位可以填【0,(digit[i]-1)】这个区间的数
若这一位之前挨着49,那么加上 dp[i-1][0] * digit[i] 也是显然OK。
若这一位之前没有挨着49,但是digit[i]比4大,那么当这一位填比digit[i]小的4的时候,就得加上dp[i-1][1](以9开头的数字的方案数)

*/
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<map>
#include<cstring>
#include<string>
#include<set>
#include<stack>
#include<queue>
#include<iomanip>
const int MAX=21;
__int64 dp[MAX][3];
int digit[MAX];
using namespace std;
int main()
{
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1;i<20;i++)
    {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];
        dp[i][1]=dp[i-1][0];
        dp[i][2]=dp[i-1][2]*10+dp[i-1][1];
    }
    int t,len,i,j,p,before;
    __int64 sum,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(digit,0,sizeof(digit));
        len=0;
        sum=0;
        before=0;
        while(n)
        {
            digit[++len]=n%10;
            n/=10;
        }
        bool p=false;
        for(i=len;i>=1;i--)
        {
            sum += dp[i-1][2] * digit[i];
            if(p)
                sum += dp[i-1][0] * digit[i];
            if(!p && digit[i] >4)
                sum += dp[i-1][1];
            if(before == 4 && digit[i] == 9)
                p = true;
            before = digit[i];

        }
        if(p)
            sum++;
        cout<<sum<<endl;
    }
    return 0;
}


 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值