POJ2398-Toy Storage

Toy Storage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3790 Accepted: 2229

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1
//AC代码(简单几何题)
/*
此题是2318的升级,只要把木板(因为木板是乱的)按升序排序下再计算
题意:还是一个长方形箱子里面分散了m个玩具(左上角(x1,y1),右下角(x2,y2))
然后插入n块木板把长方形箱子分成n+1块区域
要你求每块区域有多少个玩具,并且求出的玩具数按照升序排序
例如:假设长方形箱子被分成5块区域(按照0->4编号),那么就意味着有4块木板并且假设箱子里放了6个玩具
那么假设0号区域有2个玩具,1号区域有1个玩具,2号区域有2个玩具,3号区域有1个玩具,4号区域有0个玩具
那么最后的结果就是
Box(注意0个玩具的区域个数不显示)
1: 1(1个玩具的区域有1个)
2: 2(2个玩具的区域有2个)
*/

#include<iostream>
#include<cmath>
#include<queue>
#include<algorithm>
#include<cstring>
const int Max=1001;
int sum[Max];
int Count[Max];
using namespace std;
typedef struct Node
{
    double x;
    double y;
    int num;
}point;
point node_l[Max],node_r[Max],node_c[Max];
bool cmp(point a,point b)//把木板排序(升序)
{
    return a.x<b.x;
}
double xmult(double x1,double y1,double x2,double y2,double x0,double y0)//求叉积
{
    //cout<<x1<<" "<<y1<<" "<<x2<<" "<<y2<<" "<<x0<<" "<<y0<<endl;
	return(x1-x0)*(y2-y0)-(x2-x0)*(y1-y0);
}
int main()
{
    int n,m,i,j;
    double x1,y1,x2,y2,x,y;
    while(cin>>n&&n)
    {
        cin>>m>>x1>>y1>>x2>>y2;
        memset(sum,0,sizeof(sum));
        memset(Count,0,sizeof(Count));
        for(i=0;i<n;i++)
        {
            cin>>node_l[i].x>>node_r[i].x;
            node_l[i].y=y1;
            node_r[i].y=y2;
            node_c[i].x=(node_l[i].x+node_r[i].x)/2;
            node_c[i].y=(node_l[i].y+node_r[i].y)/2;
            node_c[i].num=i;
        }
        node_l[n].x=x2;
        node_l[n].y=y1;
        node_r[n].x=x2;
        node_r[n].y=y2;
        node_c[n].x=(node_l[n].x+node_r[n].x)/2;
        node_c[n].y=(node_l[n].y+node_r[n].y)/2;
        node_c[n].num=n;
        sort(node_c,node_c+(n+1),cmp);
        for(i=0;i<m;i++)
        {
            cin>>x>>y;
            for(j=0;j<=n;j++)
            {
                int p=node_c[j].num;
                //cout<<p<<endl;
                if(xmult(node_l[p].x,node_l[p].y,node_r[p].x,node_r[p].y,x,y)<0)
                {
                    sum[p]+=1;
                    break;
                }
            }
        }
        cout<<"Box"<<endl;
        for(i=0;i<=n;i++)
        {
            if(sum[i]!=0)
            {
                 Count[sum[i]]+=1;
            }
        }
        for(i=1;i<=m;i++)
        {
            if(Count[i]!=0)
                cout<<i<<": "<<Count[i]<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值