POJ1654-Area

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14666 Accepted: 4124

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

Source

//AC代码
/*
题意:在一个平面直角坐标系,一个点总是从原点出发,但是每次移动只能移动8个方向的中的一个并且每次移动距离
只有1和√2这两种情况,最后一定会回到原点(以字母5结束),请你计算这个点所画出图形的面积
此题是利用几何叉积计算多边形面积
*/
#include<iostream>
#include<queue>
#include<cstring>
#include<string>
#include<stack>
#include<map>
#include<algorithm>
#include<cstdio>
#include<iomanip>
#include<cmath>
const double eps=1e-8;
const double PI=3.1415926;
const int Max=1000001;
int dir[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{-1,1},{1,-1},{-1,-1}};//8个方向
#define zero(x) (((x)>0?(x):-(x))<eps)
using namespace std;
char str[Max];
int main()
{
    int T;
    int n,m,i,j;
    int x,y,u,v;
    long long A;
    cin>>T;
    while(T--)
    {
        cin>>str;
        n=strlen(str);
        x=0;
        y=0;
        A=0;
        for(i=0;i<(n-1);i++)
        {
            if(str[i]=='8')
            {
                u=x+dir[0][0];
                v=y+dir[0][1];
            }
            else if(str[i]=='2')
            {
                u=x+dir[1][0];
                v=y+dir[1][1];
            }
            else if(str[i]=='6')
            {
                u=x+dir[2][0];
                v=y+dir[2][1];
            }
            else if(str[i]=='4')
            {
                u=x+dir[3][0];
                v=y+dir[3][1];
            }
            else if(str[i]=='9')
            {
                u=x+dir[4][0];
                v=y+dir[4][1];
            }
            else if(str[i]=='7')
            {
                u=x+dir[5][0];
                v=y+dir[5][1];
            }
            else if(str[i]=='3')
            {
                u=x+dir[6][0];
                v=y+dir[6][1];
            }
            else if(str[i]=='1')
            {
                u=x+dir[7][0];
                v=y+dir[7][1];
            }
            A+=(u*y)-(v*x);//(u,v),(x,y)和(0,0)原点的叉积算出三角形的面积
            x=u;
            y=v;
        }
        if(A<0)//顺时针计算是负值
            A=-A;
        if(A%2==0)//如果面积可以整除2那么不会有精度缺失
            cout<<A/2<<endl;
        else//否则要加上0.5
            cout<<A/2<<".5"<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值