2013 - ECJTU 暑期12级训练赛第一场-Problem-H

H -H
Crawling in process...Crawling failedTime Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. 
However, when he picked it up, the maze began to shake,
 and the doggie could feel the ground sinking. He realized that the bone was a trap, 
and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. 
At the beginning, the door was closed
 and it would open at the T-th second for a short period of time (less than 1 second). 
Therefore the doggie had to arrive at the door 
on exactly the T-th second. In every second, 
he could move one block to one of the upper, lower, left and right neighboring blocks.
 Once he entered a block, the ground of this block would start to sink and disappear in the next second. 
He could not stay
 at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? 
Please help him.
  Input
The input consists of multiple test cases. 
The first line of each test case contains three integers N, M, 
and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze
 and the time at which the door will open,  respectively.
 The next N lines give the maze layout, with each line containing M characters. 
A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input

     
     
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output

     
     
NO YES
AC代码和详解:
#include<iostream>
#include<cmath>
#include<cstring>
#include<queue>
int fangxiang[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
const int MAX=101;
char map[MAX][MAX];
int mark[MAX][MAX];
int  n,m,t;
int start_x,start_y;
int end_x,end_y;
using namespace std;
bool DFS(int x,int y,int step)
{
	int i,a,b;
	if(map[x][y]=='D'&&step==t)
	return true;
	if(x<1||x>n|y<1||y>m)
	return false;
	if(step>=t)//剪枝1:当step>=T时还没有找到D点 
	return false;
	if(t-step<(abs(x-end_x)+abs(y-end_y)))//剪枝2:还需要的步数比理论上的最短距离还小  
	return false;
	if((t-step-(abs(x-end_x)+abs(y-end_y)))%2!=0) //剪枝3:比理论上的最短距离多出来的必是偶数 
	return false;
	for(i=0;i<4;i++)
	{
		a=x+fangxiang[i][0];
		b=y+fangxiang[i][1];
		if(a<=n&&a>=1&&b>=1&&b<=m&&map[a][b]!='X'&&!mark[a][b])
		{ //判断三个条件:1.检验_x,_y是否越界。2.看vis[][]是否访问过//3.看map[][]是否是墙 

			mark[a][b]=1;
			if(DFS(a,b,step+1))
			return true;
			else
			mark[a][b]=0;
		}
	}
	return false;
}
int main()
{
	int i,j;
	while(cin>>n>>m>>t&&(n||m||t))
	{
		memset(mark,0,sizeof(mark));
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
			 	cin>>map[i][j];
			 	if(map[i][j]=='S')
			 	{
 					start_x=i;
 					start_y=j;
 				}
 				if(map[i][j]=='D')
 				{
				 	end_x=i;
					end_y=j;	
		 		}
			}
		}
		mark[start_x][start_y]=1;
		if(DFS(start_x,start_y,0))
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}
	return 0;
}


 
  
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值