杭电2710-Max Factor

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2793    Accepted Submission(s): 873


Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
  
  
4 36 38 40 42
 

Sample Output
  
  
38
题目的意思是求给出的几个数值中的最大且为素数的除数(即求本身范围内的最大素数比其他数的本身最大素数还要大的数)
AC代码:
#include<iostream>/*题目的意思是求给出的几个数值中的最大且为素数的除数*/  
const int MAX=20005;
int s[MAX];
using namespace std;
int main()
{
	int n,m,maxn,i,j,p;
	memset(s,0,sizeof(s));
	s[1]=1;
	for(i=2;i<MAX;i++)//筛选所有范围内的素数 
	{
		if(s[i]==0)
		for(j=i;j<MAX;j+=i)
		{
			s[j]=i;
		}
	}
	while(cin>>n)
	{
		maxn=-1;
		while(n--)
		{
			cin>>m;
			if(s[m]>maxn)
			{
				maxn=s[m];
				p=m;
			}
		}
		cout<<p<<endl;
	}
	return 0;
}
 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值