杭电1083-Courses

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2691    Accepted Submission(s): 1247


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
  
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
  
  
YES NO
题目解释,英语不好的看看吧
Consider a group of N students and P courses. 
有N个学生,P门课

Each student visits zero,
one or more than one courses. 
每一个学生学习一些课程。

Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:
你的任务是判断是否能可能P个学习符合下面的情况。

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)
每一个学生参加不同的课程

. each course has a representative in the committee
每一个课程都有学生参加。

解题报告:因为课程有P个,而且只选择P个学生,每一个学生加参的课程不同,而且每一门课都

有学生参加,这就是说有P个学生和这P门课一一对应,也就是最大二分匹配问题。

/*题意:有p门课程,n个学生,每个学生在一个committee代表一门课程,求学生和课程的最大匹配
若最大匹配等于p,输出YES,否则输出NO。
直接用匈牙利算法就可以求解。*/
#include<iostream>//匈牙利算法求最大匹配
#include<cstring>
#include<cstdio>
const int MAX=301;
int map[MAX][MAX];//保存已经匹配关系
int mark[MAX];//是否查找过
int pipei[MAX];//保存匹配关系
int n;//学生人数
int p;//课程数目
using namespace std;
bool find(int x)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(!mark[i]&&map[x][i])
        {
            mark[i]=1;
            if(pipei[i]==-1||find(pipei[i]))
            {
                pipei[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int t,p,m,i,j,sum;
    cin>>t;
    while(t--)
    {
        cin>>p>>n;
        memset(map,0,sizeof(map));
        for(i=1;i<=p;i++)
        {
            cin>>m;
            while(m--)
            {
                cin>>j;
                map[i][j]=1;
            }
        }
        sum=0;
        memset(pipei,-1,sizeof(pipei));
        for(i=1;i<=p;i++)
        {
            memset(mark,0,sizeof(mark));
            if(find(i))
            sum+=1;
        }
        if(sum==p)
        cout<<"YES"<<endl;
        else
        cout<<"NO"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值