杭电3549-Flow Problem

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 5364    Accepted Submission(s): 2510


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
这是本人做的第一道最大流
做最大流当然用EK算法
AC代码+解释:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<iomanip>
const int MAX=1001;
int max_flow[MAX][MAX];
int Queue[MAX];//队列数组
int mark[MAX];
using namespace std;
int EK(int n)//最大流模板
{
    int ans,Min,end,temp;
    ans=0;
    while(true)
    {
        int head,tail,i;
        head=0;
        tail=0;
        Queue[++tail]=1;
        memset(mark,0,sizeof(mark));
        mark[1]=1;
        while(head<tail)//存在增广路(这里是BFS广搜)
        {
            temp=Queue[++tail];
            if(temp==n)//如果搜到汇点就跳出
            break;
            for(i=1;i<=n;i++)
            {
                if(!mark[i]&&max_flow[temp][i])//如果存在路径
                {
                    mark[i]=temp;//标记
                    Queue[++head]=i;//加入队列
                }
            }
        }
        if(mark[n]==0)//如果不存在增广路,结束循环
        break;
        Min=MAX;
        for(end=n;end!=1;end=mark[end])//每次回溯,找出增广路中最小流
        {
            if(Min>max_flow[mark[end]][end])
            Min=max_flow[mark[end]][end];
        }
        ans+=Min;
        for(end=n;end!=1;end=mark[end])//正向减去反向相加
        {
            max_flow[mark[end]][end]-=Min;
            max_flow[end][mark[end]]+=Min;
        }
    }
    return ans;
}
int main()
{
    int t,n,m,i,j,a,b,c,p;
    cin>>t;
    p=1;
    while(t--)
    {
        cin>>n>>m;
        memset(max_flow,0,sizeof(max_flow));
        for(i=1;i<=m;i++)
        {
            cin>>a>>b>>c;
            max_flow[a][b]+=c;
        }
        cout<<"Case "<<p++<<": ";
        cout<<EK(n)<<endl;
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值