ZOJ What day is that day? (找最小周期)

It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input
2
1
2
Sample Output
Sunday
Thursday
Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday. 

#include<stdio.h>
#include<math.h>
int c[297];
void init()
{
    int a;
    c[0]=1;
    for(int i=1;i<=295;i++)
    {
        a=(i+1)%7;
        for(int j=2;j<=i+1;j++)
        a=(a*(i+1))%7;

        c[i]=(c[i-1]+a)%7;
    }
}
int main()
{init();
    int n,t;
    char day[8][20]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        n%=294;
        if(n)n--;
        else n=293;
        int d=c[n];
        if(d)d-=1;
        else d=6;
        printf("%s\n",day[d]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值