HDU1232 畅通工程

Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

Sample Input
  
  
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
  
  
1 0 2 998
Hint
Hint
Huge input, scanf is recommended. http://blog.csdn.net/dellaserss/article/details/7724401 初步了解并查集
import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main {

	static int[] pre;
	static int[] cal;

	public static void main(String[] args) {
		Scanner cin = new Scanner(new BufferedInputStream(System.in));

		while (cin.hasNext()) {
			int N = cin.nextInt();
			if(N == 0) break;
			int M = cin.nextInt();

			pre = new int[N + 1];
			cal = new int[N + 1];
			for (int i = 1; i <= N; i++) {
				pre[i] = i;
			}

			for (int i = 0; i < M; i++) {
				int x = cin.nextInt();
				int y = cin.nextInt();
				join(x, y);
			}

			int ans = 0;
			for (int i = 1; i <= N; i++) {
				if (pre[i] == i) {
					ans++;
				}
			}

			System.out.println(ans - 1);
		}
		cin.close();
	}

	static void join(int x, int y) {
		int px = getGrandpa(x);
		int py = getGrandpa(y);

		if (px != py) {
			pre[px] = py;
		}
	}

	static int getGrandpa(int x) {
		int r = x;
		while (pre[r] != r) {
			r = pre[r];
		}

		int i = x, j; 
		while(pre[i] != r) {
			j = pre[i];
			pre[i] = r;
			i = j;
		}
		return r;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值