10002 - Center of Masses


 Center of Masses 

Find out the center of masses of a convex polygon.

Input 

A series of convex polygons, defined as a number n ( $n \le 100$)stating thenumber of points of the polygon, followed by n different pairs of integers(in no particular order), denoting the x and y coordinates of each point.The input is finished by a fake ``polygon" with m ( m < 3) points, whichshould not be processed.

Output 

For each polygon, a single line with the coordinates xand y of the center of masses of that polygon, rounded to three decimaldigits.

Sample Input 

4 0 1 1 1 0 0 1 0
3 1 2 1 0 0 0
7
-4 -4
-6 -3
-4 -10
-7 -12
-9 -8
-3 -6
-8 -3
1

Sample Output 

0.500 0.500
0.667 0.667
-6.102 -7.089
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct point
{double x;double y;
point(double x=0, double y=0):x(x),y(y){}
}p[100005],a,ch[100005];

typedef point vector;

vector operator-(point a,  point b){return vector(a.x-b.x,a.y-b.y);}
double cross(vector a, vector b){return a.x*b.y-a.y*b.x;}
double cross3(point a,point b,point c){return (c.x-a.x)*(b.y-a.y)-(b.x-a.x)*(c.y-a.y);}  
bool operator<(const point& a,const point& b){return a.x<b.x||(a.x==b.x&&a.y<b.y);}  

int convexhull(point *p,int n,point *ch)
{
	sort(p,p+n);
	int m=0;
	for(int i=0;i<n;i++)
	{
		while(m>1&&cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0)
			m--;
		ch[m++]=p[i];
	}
	int k=m;
	for(int i=n-2;i>=0;i--)
	{
		while(m>k&&cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0)	
			m--;
		ch[m++]=p[i];
	}
	if(n>1) m--;
	return m;
}

point center(point *p,int n)
{
	point ans,t;  
	double area=0.0,t2;  
	ans.x = 0.0; ans.y = 0.0;  
	for(int i=1; i<n-1; i++)  
	{  
		t2 = cross3(p[i],p[0],p[i+1])/2.0;  
		ans.x += (p[0].x + p[i].x + p[i+1].x)*t2;  
		ans.y += (p[0].y + p[i].y + p[i+1].y)*t2;  
		area += t2;  
	}  
	ans.x/=(3*area);ans.y/=(3*area);  
	return ans;  
}

int main()
{
	int n;
	while(cin>>n)
	{
		if(n<3) break;
		for(int i=0;i<n;i++)
			cin>>p[i].x>>p[i].y;
		convexhull(p,n,ch);
		point ans=center(ch,n);
		printf("%.3lf %.3lf\n",ans.x,ans.y);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值