Maven 解决依赖Jar包冲突

Question

之前引用程序的时候,发现有的Jar包版本不是我所需要的版本。在依赖Jar 包外面又引用了一遍,导致Jar包依赖错误。


Solution

修改pom.xml文件,去除不需要jar包,引入需要的jar。保证同一个jar包直邮一个版本的jar包。

例如(去除scala2.11.10 引入scala2.11.8):

<dependencies>
		<!-- https://mvnrepository.com/artifact/org.apache.kafka/kafka -->
		<dependency>
			<groupId>org.apache.kafka</groupId>
			<artifactId>kafka_2.11</artifactId>
			<version>1.0.0</version>
			<exclusions>
				<exclusion>
					<groupId>org.scala-lang</groupId>
					<artifactId>scala-library</artifactId>
				</exclusion>
			</exclusions>
		</dependency>
<!-- https://mvnrepository.com/artifact/org.scala-lang/scala-library -->
		<dependency>
			<groupId>org.scala-lang</groupId>
			<artifactId>scala-library</artifactId>
			<version>2.11.8</version>
		</dependency>
<dependencies>

Reference

暂无

此Demo的Github地址:
https://github.com/SeanYanxml/bigdata

相关推荐
©️2020 CSDN 皮肤主题: Age of Ai 设计师:meimeiellie 返回首页