hdu4722 Good Numbers

44 篇文章 0 订阅

Good Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 45 Accepted Submission(s): 14


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.

Sample Input
  
  
2 1 10 1 20

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.

Source

Recommend
zhuyuanchen520
找规律题,水题!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
__int64 ff(__int64 m)
{
    if(m<0)
    return 0;
    __int64 temp=m/100,ans;
    __int64 i;
    ans=temp*10;
    for(i=temp*100;i<=m;i++)
    {
       __int64 sum=0,t=i;
       while(t)
       {
           sum+=t%10;
           t/=10;
       }
      if(sum%10==0)
      ans++;
    }
    return ans;
}
int main()
{
    int tcase ,tt=1;
    __int64 a,b;
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%I64d%I64d",&a,&b);
        printf("Case #%d: %I64d\n",tt++,ff(b)-ff(a-1));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值