hdu3404 Switch lights

67 篇文章 1 订阅

Switch lights

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 341 Accepted Submission(s): 180


Problem Description
lxhgww is playing a game with his computer Deep Blue.
The game is played on a matrix containing lights. At first, some lights are on, while others are off. lxhgww and Deep Blue take turns to switch the lights. For each step, the player should choose a rectangle in the matrix: (x1 , y1) , (x1 , y2) , (x2 , y1) , (x2 , y2) , (x1<=x2,y1<=y2, the light at (x2, y2) should be on) and change the lights’ status on the four vertex of the rectangle, namely on to off, and off to on. The player turns all the lights off wins the game. Notice the rectangle is possibly degenerated to line or even a single cell so that the player may also switch two or one besides four lights in a move.
Deep Blue's strategy is perfect, if it has a chance to win, never will it lose. Does lxhgww have a chance to win if he takes the first step?

Input
The first line is an integer T(T<=100) indicating the case number.
Each case has one integers n (n<= 1000 ), the number of on-lights at the beginning of the game.
Then come n lines, each line has two integers, xi , yi, (1<=xi<=10000, 1<=yi<=10000) , so light at (xi, yi) is on at first. (No two lights at the same position)

Output
If lxhgww still has a chance to win, output "Have a try, lxhgww.", otherwise tell lxhgww "Don't waste your time."

Sample Input
  
  
2 2 1 2 2 1 2 1 1 2 2

Sample Output
  
  
Don't waste your time. Have a try, lxhgww.
坑啊,这题不好做,推荐看从“k 倍动态减法游戏”出发探究一类组合游戏问题这篇论文,很详细,但是不好懂!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int pri[2][2]={0,0,0,1};
int get(int x,int y){
    if(x<2)return pri[x][y];
    int i,p,t,s,m;
    for(i=0;;i++){
        if(((1<<(1<<i))<=x)&&(x<(1<<(1<<(i+1)))))
        break;
    }
    m=1<<(1<<i);
    p=x/m,s=y/m,t=y-s*m;
    int c1=get(p,s);
    int c2=get(p,t);
    return m*(c1^c2)^get(m/2,c1);

}
int getsg(int x,int y){
    if(x<y)return getsg(y,x);
    if(x<2)return pri[x][y];
    int i,p,t,s,q,m;
    for(i=0;;i++){
        if(((1<<(1<<i))<=x)&&(x<(1<<(1<<(i+1)))))
        break;
    }
    m=1<<(1<<i);
    p=x/m,q=x-p*m,s=y/m,t=y-s*m;
    int c1=getsg(p,s);
    int c2=getsg(p,t)^getsg(q,s);
    int c3=getsg(q,t);
    return m*(c1^c2)^c3^get(m/2,c1);
}
int main()
{
    int tcase,i,x,y,ans,n;
    scanf("%d",&tcase);
    while(tcase--){
        scanf("%d",&n);
        for( i=0,ans=0;i<n;i++){
            scanf("%d%d",&x,&y);
            ans^=getsg(x,y);
        }
        if(ans)printf("Have a try, lxhgww.\n");
        else printf("Don't waste your time.\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值