poj3537 Crosses and Crosses

67 篇文章 1 订阅
Crosses and Crosses
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 2250 Accepted: 827
Case Time Limit: 2000MS

Description

The game of Crosses and Crosses is played on the field of 1 × n cells. Two players make moves in turn. Each move the player selects any free cell on the field and puts a cross ‘×’ to it. If after the player’s move there are three crosses in a row, he wins.

You are given n. Find out who wins if both players play optimally.

Input

Input file contains one integer number n (3 ≤ n ≤ 2000).

Output

Output ‘1’ if the first player wins, or ‘2’ if the second player does.

Sample Input

 
 
#13
#26

Sample Output

一个人,如果在i处放了,那么另一个肯定不能放在它的左和右2格,那么就分成了两个游戏,i-3和n-i-2;

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
char str[100];
int dp[2500];
int dfs(int n){
    //printf("%d ",n);
    if(n<=0)return 0;
    if(dp[n]!=-1)return dp[n];
    bool vis[10000];
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++){
        vis[dfs(i-3)^dfs(n-i-2)]=true;
    }
    for(int i=0;;i++)
    if(!vis[i])
    return dp[n]=i;
}
int main()
{
    int i,n;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d",&n)!=EOF){
        if(dfs(n))printf("1\n");
        else printf("2\n");
    }
    return 0;
}


 
 
#11
#22
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值