Poj 3278 Catch That Cow 裸bfs

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 42411 Accepted: 13189

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

大致题意:

给定两个整数n和k

通过 n+1或n-1 或n*2 这3种操作,使得n==k

输出最少的操作次数

 

解题思路:

说实话,要不是人家把这题归类到BFS,我怎么也想不到用广搜的= = 自卑ing。。。

 

水题水题,三入口的BFS

 

注意的地方有二:

1、  由于用于广搜的 队列数组 和 标记数组  相当大,如果定义这两个数组时把它们扔到局部去,编译是可以的,但肯定执行不了,提交就等RE吧= =

大数组必须开为 全局 。。。常识常识。。。

2、  剪枝。直接广搜一样等着RE吧= =

不剪枝的同学试试输入n=0  k=100000。。。。。。铁定RE

怎么剪枝看我程序



#include <stdio.h>
#include <queue>
#include <string.h>

using namespace std;
int a[1000005];
void bfs(int N, int K)
{
	queue<int> q;
	q.push(N);

	while(q.size())
	{
		int p = q.front();
		q.pop();

		if(p == K)
			break;

		else
		{
			if(p <= K && a[p+1] == 0)
			{
				q.push(p+1);
				a[p+1] = a[p] + 1;
			}

			if(p <= K && a[2*p] == 0)
			{
				q.push(2 * p);
				a[2*p] = a[p] + 1;
			}

			if(p-1 >= 0 && a[p-1] == 0)
			{
				q.push(p-1);
				a[p-1] = a[p] + 1;
			}
		}

	}
}


int main()
{
	int N, K;
	while(scanf("%d%d",&N,&K) != EOF)
	{
		memset(a, 0, sizeof(a));
		bfs(N,K);
		printf("%d\n",a[K]);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值