UVA 548 (树的重建 以及遍历 13.08.19)

  Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255


题意: 按输入给的中序和后序建树, 然后从根节点走起, 连接各个叶子结点, 在这么多条树枝中, 求哪一条走下来, 结点的和是最小的, 将该条树枝的叶子结点输出~


做法: 按中序和后续建树, 接着遍历, 不断更新最小值, 最后输出~


AC代码:

#include<stdio.h>
#include<string.h>

int min;
int ans;
int in[10005], post[10005];

struct Node{
    int num;
    Node *left;
    Node *right;
};

//建树:
Node* build(int l, int *i, int *p) {
    if(l == 0)
        return NULL;
    int pos = 0;
    while(i[pos] != p[l-1])
        pos++;
    Node *r = new Node;
    r->num = p[l-1];
    r->left = build(pos, i, p);
    r->right = build(l-pos-1, i+pos+1, p+pos);
    return r;
}

//遍历:
void search(Node *r, int n) {
    if(r->left == NULL && r->right == NULL) {
        if(r->num + n <= min) {
            min = r->num + n;
            ans = r->num;
        }
        return ;
    }
    if(r->left != NULL)
        search(r->left, r->num+n);
    if(r->right != NULL)
        search(r->right, r->num+n);
}

int main() {
    while(scanf("%d", &in[0]) != EOF) {
        int len = 1;
        while(getchar() != '\n')
            scanf("%d", &in[len++]);
        for(int i = 0; i < len; i++)
            scanf("%d", &post[i]);
        min = 99998;
        Node *root = build(len, in, post);
        search(root, 0);
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值