UVA 465 (13.08.02)

 Overflow 

Write a program that reads an expression consisting of twonon-negative integer and an operator. Determine if either integer orthe result of the expression is too large to be represented as a``normal'' signed integer (typeinteger if you are workingPascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, oneof the two operators+ or *, and another integer.

Output

For each line of input, print the input followed by 0-3 linescontaining as many of these three messages as are appropriate: ``firstnumber too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big


题意:输入num1 + 或 * num2

若num1大于int可表示的最大值, 那么输出"first number too big"

同理num2的话, 输出"second number too big"

最后还要判定结果是否溢出, 若溢出, 输出"result too big"

都没溢出, 那么就没输出~


AC代码:

#include<stdio.h>
#include<stdlib.h>

#define MAX 2147483647

int main() {
	char num1[600], num2[600];
	char ch;
	double n1, n2;
	while(scanf("%s %c %s", num1, &ch, num2) != EOF) {
		printf("%s %c %s\n", num1, ch, num2);
		n1 = atof(num1);
		n2 = atof(num2);
		if(n1 > MAX)
			printf("first number too big\n");
		if(n2 > MAX)
			printf("second number too big\n");
		if(ch == '+' && n1+n2 > MAX)
			printf("result too big\n");
		if(ch == '*' && n1*n2 > MAX)
			printf("result too big\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值