POJ 1160 Post Office

Post Office
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13732 Accepted: 7393

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

题意:

v个村庄要建p个邮局,邮局只能建在村庄里面,求各个村庄到其附近最近邮局的距离之和

解析:

知道是dp,但是自己想了半天却不知道状态转移方程怎么写。后来看了解题报告才明白,果断acm之路还有很长要走啊奋斗,具体思路就是dp[i][j]代表前i个村庄里面建j个邮局得到的最小距离,状态转移方程就是:dp[i][j] = { dp[k][j-1] + f[k][i] } (j-1<=k<=i),分成前k个村庄有j-1个邮局,然后f[k][j]代表第k个村庄到第i个村庄之间建一个邮局的最短距离(明显就是这些村庄的中位数了),k要从j-1个村庄(因为有j-1个邮局至少有j-1个村庄)到i个村庄循环一次

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[310][31],f[310][310];//d[i][j]代表前i个村庄里有j个邮局的最优解,f[i][j]代表第i个村庄到
//第j个村庄中选个最优邮局
int v,p;
int pos[310];

int cmp(int a,int b)
{
	return a < b;
}

int main()
{
	while(scanf("%d%d",&v,&p) != EOF )
	{
		memset(pos,0,sizeof(pos));
		memset(dp,0,sizeof(dp));
		memset(f,0,sizeof(f));

		int i,j,k;
		for(i = 1; i <= v; i ++)
			scanf("%d",&pos[i]);
		sort(pos+1,pos+v+1,cmp);//排序
		
		for(i = 1 ; i <= v;i ++)//初始化f数组
			for(j = i ; j <= v; j ++)
				for(k = i;k <= j ;k ++)
				{
					int abs,mid = (i+j)/2;
					abs = (pos[k] - pos[mid]) > 0 ? pos[k] - pos[mid]: pos[mid] - pos[k];
					f[i][j] +=	abs;
				}

		for(i = 1 ;i <= v ;i ++)//开始dp
		{
			dp[i][1] = f[1][i];
			//若循环时j从1开始,那么dp[k][j-1]=0,temp = f[k+1][i]有错误,所以j从2开始,
			for(j = 2;j <= p && j <= i;j ++)
			{
				int min = 100000000;
				for(k = j - 1 ; k < i ; k ++)
				{	
					int temp = (dp[k][j-1] + f[k+1][i]);//需要用另一个变量存储,因为函数只能
					//递归一次
					min > temp ? min = temp :0;
				}
				dp[i][j] = min;

			}
		}
		printf("%d\n",dp[v][p]);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值