pku 3126 Prime Path (bfs)

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9260 Accepted: 5275

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source


题意:由一个素数变成另一个素数,一次变化一个数字,中途的数不能是素数也不能少于1000
题解:bfs搜索...不想说

#include<string.h>
#include<stdio.h>
int x,tagx;
int vis[10005],mark[10005];
struct pa{
   int x,t;
}que[10000005],now,temp;
void div()
{
    int i,j;
   memset(mark,0,sizeof(mark));
   for(i=2;i<=9999;i++)
   {
      if(mark[i]) continue;
      for(j=i*i;j<=9999;j+=i) mark[j]=1;
   }
}
int change(int x,int i,int j)
{
   int a[5],ans=0,k;

   for(k=0;k<4;k++) a[k]=x%10,x/=10;
   a[i]=j;
   for(k=0;k<4;k++) ans=ans*10+a[3-k];

   return ans;
}
int bfs()
{
   int sta=0,fin=1,y,i,j;

   memset(vis,0,sizeof(vis));
   now.x=x,now.t=0;
   que[0]=now;
   while(sta<fin)
   {
      now=que[sta++];
      vis[now.x]=1;
      if(now.x==tagx) return now.t;
      for(i=0;i<4;i++)
      {
         for(j=0;j<10;j++)
         {
            y=change(now.x,i,j);
            if(y<1000) continue;
            if(vis[y]) continue;
            if(mark[y]) continue;
            temp.x=y; temp.t=now.t+1;
            que[fin++]=temp;
         }
      }
   }

   return -1;
}
int main()
{
   int res,t;

   div();
   scanf("%d",&t);
   while(scanf("%d%d",&x,&tagx)>0)
   {
      res=bfs();
      if(res==-1) printf("Impossible\n");
      else printf("%d\n",res);
   }

   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值