杭电4300kmp

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2906    Accepted Submission(s): 1119


Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

Output
For each test case, output one line contains the shorest possible complete text.
 

Sample Input
  
  
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

Sample Output
  
  
abcdabcd qwertabcde
 

Author
BUPT
 

Source

两个样例:
1.   agctagcagctagctg
2.   abababa
开始我一直想用next数组来求出他的循环节,
但这样会忽视一种情况:
   abababa
   0012345
这样len-next【len-1】(我开始把它看成求出循环节)就会出问题了。。。
应输出:abababab
所以还是要用kmp来匹配。。

#include <cstdio>
#include <cstring>
#define MAXN 100010
int t;
char val[30];
char stu[MAXN];
char ff[MAXN];
int next[MAXN];
void getnext(const char *Pattern, int prefix[])
{
     int len=strlen(Pattern);//模式字符串长度。
     prefix[0]=0;
     for(int i=1; i<len; i++)
     {
         int k=prefix[i-1];
         //不断递归判断是否存在子对称,k=0说明不再有子对称,Pattern[i] != Pattern[k]说明虽然对称,但是对称后面的值和当前的字符值不相等,所以继续递推
         while( Pattern[i] != Pattern[k]  &&  k!=0 )
             k=prefix[k-1];     //继续递归
         if( Pattern[i] == Pattern[k])//找到了这个子对称,或者是直接继承了前面的对称性,这两种都在前面的基础上++
              prefix[i]=k+1;
         else
              prefix[i]=0;       //如果遍历了所有子对称都无效,说明这个新字符不具有对称性,清0
     }
}
int kmp(const char T[],const char P[],int next[])
 {
     int n,m;
     int i,q;
     n = strlen(T);
     for (i = 0,q = 0; i < n; ++i)
     {
         while(q > 0 && P[q] != T[i])
             q = next[q-1];
         if (P[q] == T[i])
         {
             q++;
         }
     }
     return q;
 }

int main()
{
    int i,n,t,j,len;
    scanf("%d",&n);getchar();
    while(n--)
    {
        scanf("%s",val);getchar();
        scanf("%s",stu);getchar();
        printf("%s",stu);
        strcpy(ff,stu);
        len=strlen(stu);
        t=len%2?len/2+1:len/2;
        strcpy(stu,stu+t);
        for(i=0;i<len;++i)
        {
            for(j=0;j<26;++j)
            {
                if(ff[i]==val[j])
                {
                    ff[i]=j+'a';
                    break;
                }
            }
        }
        getnext(ff,next);
        int p=kmp(stu,ff,next);
        for(i=p;i<len-p;++i)
        {
            printf("%c",ff[i]);
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值