杭电1251

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 15313    Accepted Submission(s): 6558


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
只要会建树就会做了。。
模版题 。
#include <cstdio>
#include <cstdlib>
#include <cstring>
struct node
{
    int count;
    node *x[26];
};
node *tree;
char stu[20];
void create(node *&t)
{
    int i;
    t=(node*)malloc(sizeof(node));
  //   printf("t  = %d \n",t);
    t->count=0;
    for(i=0;i<26;++i)
        t->x[i]=NULL;
}
void insertTree()
{
    node *f=tree;
    int i,j,len=strlen(stu);
    for(i=0;i<len;++i)
    {
        int p=stu[i]-'a';
        if(f->x[p]==NULL)
        {
         //   printf("if\n");
            f->x[p]=(node *)malloc(sizeof(node));
            f=f->x[p];
            for(j=0;j<26;++j)
                f->x[j]=NULL;
            f->count=1;
         //   printf("f=%d f->count =%d\n",f,f->count);
        }
        else
        {
       //     printf("else\n");
            f=f->x[p];
            f->count++;
     //       printf("f=%d f->count =%d\n",f,f->count);
        }
    }
}
int chazhao()
{
    node *f=tree;
    int i,len=strlen(stu);
    for(i=0;i<len;++i)
    {
        int p=stu[i]-'a';
        if(f->x[p]==NULL)
        {
            return 0;
        }
        else
        {
            f=f->x[p];
            if(i==len-1)
            {
                return f->count;
            }
        }
    }
}
int main()
{
    int n;
    create(tree);
  /*  for(i=0;i<26;++i)
    {
        printf("tree x[%d] = %d  count= %d\n",i,tree->x[i],tree->count);
    }*/
    while(gets(stu)&&strlen(stu))
    {
  //       printf("stu %s  len %d\n",stu,strlen(stu));
        insertTree();
    }
    while(gets(stu))
    {
 //       printf("stu %s  len %d\n",stu,strlen(stu));
        n=chazhao();
        printf("%d\n",n);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值