hdu 1130 How Many Trees?

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2824    Accepted Submission(s): 1654


Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 

Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 5
 

Source
UVA
 

题解及代码:

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        BigInteger []s = new BigInteger[1050];
        
        s[0] = BigInteger.valueOf(1);
        s[1] = BigInteger.valueOf(1);
        s[2] = BigInteger.valueOf(2);
        s[3] = BigInteger.valueOf(5);
        
        for(int i=4;i<=100;i++)
        {
            s[i] = BigInteger.valueOf(0);
            for(int j=1;j<=i;j++)
            {
                //BigInteger n = new BigInteger(int);
                s[i]=s[i].add(s[j-1].multiply(s[i-j]));
            }
                
        }
        
        Scanner t = new Scanner(System.in);
         while(t.hasNext())
         {
             int m=t.nextInt();
             System.out.println(s[m]);
         }
    }

}
/*
题目的意思是给定n个节点,每个节点会有一个值,这些值都不相同,
问这些节点能构成多少棵不同的二分查找树

也看了一些其他人的题解,说是卡特兰数(当然结果的确是卡特兰数),
鉴于对于卡特兰数的学习比较少,我直接推导的公式

公式为:s[n]=∑s[i-1]*s[n-i];比较水的题目了,以后在学习一下卡特兰数
由于数比较大,也懒得高精度了,直接上java,有空再补上。

*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值