hdu 4920 Matrix multiplication

Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 334    Accepted Submission(s): 112


Problem Description
Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.
 

Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).
 

Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
 

Sample Input
  
  
1 0 1 2 0 1 2 3 4 5 6 7
 

Sample Output
  
  
0 0 1 2 1
 

Author
Xiaoxu Guo (ftiasch)
 

Source
 



题解及代码:


/*
签到题,简单的矩阵相乘,注意元素0的处理就不会超时了。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=3;
int a[810][810],b[810][810];
int temp[810][810];
void multiple(int n,int p)
{
    int i,j,k;
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)
        {
            if(a[i][j]!=0)
                for(k=0; k<n; k++)
                    temp[i][k]=(temp[i][k]+a[i][j]*b[j][k])%p;
        }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
            if(j==0) printf("%d",temp[i][j]);
        else printf(" %d",temp[i][j]);
        puts("");
    }
}



void init(int n)
{
   memset(temp,0,sizeof(temp));
   for(int i=0;i<n;i++)
   {
       for(int j=0;j<n;j++)
       {
          scanf("%d",&a[i][j]);
          a[i][j]%=3;
       }
   }
   for(int i=0;i<n;i++)
   {
       for(int j=0;j<n;j++)
       {
          scanf("%d",&b[i][j]);
          b[i][j]%=3;
       }
   }
}

int main()
{
    int n;
    while(cin>>n)
    {
        init(n);
        multiple(n,mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值