hdu 4927 Series 1

Series 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 596    Accepted Submission(s): 214


Problem Description
Let A be an integral series {A 1, A 2, . . . , A n}.

The zero-order series of A is A itself.

The first-order series of A is {B 1, B 2, . . . , B n-1},where B i = A i+1 - A i.

The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).

Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 

Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).

For each test case:
The first line contains a single integer n(1<=n<=3000), which denotes the length of series A.
The second line consists of n integers, describing A 1, A 2, . . . , A n. (0<=A i<=10 5)
 

Output
For each test case, output the required integer in a line.
 

Sample Input
  
  
2 3 1 2 3 4 1 5 7 2
 

Sample Output
  
  
0 -5
 

Author
BUPT
 


题解及代码:


import java.util.*;
import java.io.*;
import java.math.*;

public class Main {

    
    public static BigInteger solve(BigInteger s[],int n)
    {
        BigInteger ans=BigInteger.valueOf(0);
        BigInteger t=BigInteger.valueOf(1);
        BigInteger l=BigInteger.valueOf(1);
        BigInteger r=BigInteger.valueOf(n-1);
        int k=0;
        for(int i=n-1;i>=0;i--)
        {
           if(k%2==0) ans=ans.add(t.multiply(s[i]));
           else ans=ans.subtract(t.multiply(s[i]));
           t=t.multiply(r).divide(l);
           l=l.add(BigInteger.ONE);
           r=r.subtract(BigInteger.ONE);
           k++;
        }
        return ans;
    }
    
    public static void main(String []args)
    {
        int T,n;
        BigInteger s[]=new  BigInteger[3010];
        Scanner cin = new Scanner(System.in); 
        T=cin.nextInt();
        while(T>0)
        {
            T--;
            n=cin.nextInt();
            for(int i=0;i<n;i++)
            {
                s[i]=cin.nextBigInteger();
            }
            System.out.println(solve(s,n));
        }
    }
}
/*
简单计算一下:
以1 2 3 为例子
第二层为 (2-1) (3-2)
第三层为     3-2*2+1
还不是很明显,再以1 5 7 2 为例子:
第二层为 (5-1) (7-5) (2-7)
第三层为    (7-2*5+1) (2-2*7+5)
第四层为       2-3*7+3*5-1
这样我们就找到了规律,那就是计算从记过从右向左排列,
,每个数前面的系数依次为组合数,符号很奇偶。

由于计算结果比较大,使用java来计算就比较合适了。
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值