poj 1703 Find them, Catch them

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31412 Accepted: 9677

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.


题解及代码:

         一开始的思路有问题,本来想将最开始的两个人设为基点,因为他们两个必然对立,然后看后来人和他们的关系来判断,后来的人的关系。但是会出现,后面的人与一开始的人没关系的情况,所以wa了。


1.开始改变思路,我们使用一个set数组来记录某个人对立阵营的一个人,当判断两个人的关系时,首先我们看两个人是否在同一个root中,如果在即为一个阵营,然后我们可以判断前一个人与后一个人的set中人物的关系,如果root相同即为不同阵营,否则就是还未确定。

#include <iostream>
#include <cstdio>
using namespace std;
int root[100010],set[100010];
int n,m;

void init()
{
    for(int i=0;i<=n;i++)
        root[i]=i,set[i]=0;
}


int look(int n)
{
    if(n!=root[n])
        root[n]=look(root[n]);
    return root[n];
}

void  _union(int a,int b)
{
    a=look(a);
    b=look(b);

    if(a==b) return;

    root[b]=a;
}


int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&n,&m);
        init();
        char s[2];
        int a,b;
        while(m--)
        {
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='A')
            {
                a=look(a);
                b=look(b);
                if(a==b)
                {
                    printf("In the same gang.\n");
                }
                else if(look(set[a])==b||look(set[b])==a)
                {
                    printf("In different gangs.\n");
                }
                else printf("Not sure yet.\n");
            }
            else
            {
                if(!set[a]&&!set[b]) {set[a]=b,set[b]=a;}
                else if(!set[a]) set[a]=b,_union(set[b],a);
                else if(!set[b]) set[b]=a,_union(set[a],b);
                else _union(set[a],b),_union(set[b],a);
            }
        }
    }

    return 0;
}


2.我们可以是一个数组来记录,每个节点与起父节点的关系,在查找和合并的时候都需要更新这个数组。


#include <iostream>
#include <cstdio>
using namespace std;
int root[100010],rela[100010];
int n,m;

void init()
{
    for(int i=0; i<=n; i++)
        root[i]=i,rela[i]=0;
}


int look(int n)
{
    int t=root[n];

    if(n!=root[n])
    root[n]=look(root[n]);

    rela[n]=(rela[n]==rela[t])?0:1;
    return root[n];
}

void  _union(int a,int b,int ra,int rb)
{
    root[rb]=ra;
    rela[rb]=(rela[a]==rela[b])?1:0;
}


int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&n,&m);
        init();
        char s[2];
        int a,b;
        while(m--)
        {
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='A')
            {
                int ra=look(a);
                int rb=look(b);
                if(ra==rb)
                {
                    if(rela[a]==rela[b])
                    printf("In the same gang.\n");
                    else printf("In different gangs.\n");
                }
                else printf("Not sure yet.\n");
            }
            else
            {
                int ra=look(a),rb=look(b);
                _union(a,b,ra,rb);
            }
        }
    }

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值