poj 1753 Flip Game(高斯消元)

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30805 Accepted: 13409

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4


高斯消元简单题:


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;

int a[35][35],x[35];
int equ,var;//方程数和变元数

void Debug()
{
    for(int i=0;i<equ;i++)
    {
        for(int j=0;j<=var;j++)
            printf("%d ",a[i][j]);
        puts("");
    }
    puts("");
}

int gauss()
{
    int max_r,col=0;
    for(int i=0;i<equ&&col<var;i++,col++)
    {
        max_r=i;
        for(int j=i+1;j<equ;j++)
        {
            if(a[j][col]>a[max_r][col]) max_r=j;
        }
        if(max_r!=i)
        {
            for(int k=0;k<=var;k++)
            {
                swap(a[i][k],a[max_r][k]);
            }
        }
        if(a[i][col]==0)
        {
            i--;
            continue;
        }

        for(int j=i+1;j<equ;j++)
        if(i!=j&&a[j][col])
        {
            for(int k=col;k<=var;k++)
            a[j][k]=a[i][k]^a[j][k];
        }
    }

    //Debug();
    for(int i=equ-4;i<equ;i++)
    if(a[i][var]) return -1;

    int ans=100,sum=0;
    for(int k=0;k<=15;k++)
    {
       x[equ-1]=(k&1)>0?1:0;x[equ-2]=(k&2)>0?1:0;x[equ-3]=(k&4)>0?1:0;x[equ-4]=(k&8)>0?1:0;
       //printf("%d%d%d%d\n",x[equ-1],x[equ-2],x[equ-3],x[equ-4]);
       sum=0;
       for(int i=equ-5;i>=0;i--)
       {
        int temp=a[i][var];
        for(int j=i+1;j<var;j++)
        {
            temp-=a[i][j]*x[j];
        }
        x[i]=temp/a[i][i];
       }
       for(int i=0;i<=15;i++)
       if(x[i]%2!=0)
       {
           sum++;
       }

       //printf("  sum:%d\n",sum);
       ans=min(ans,sum);
    }
    return ans;
}


void init()
{
    memset(a,0,sizeof(a));
    memset(x,0,sizeof(x));
    for(int i=0;i<4;i++)
    for(int j=0;j<4;j++)
    {
        if(i!=0) a[i*4+j][(i-1)*4+j]=1;
        if(i!=3) a[i*4+j][(i+1)*4+j]=1;
        if(j!=0) a[i*4+j][i*4+j-1]=1;
        if(j!=3) a[i*4+j][i*4+j+1]=1;
        a[i*4+j][i*4+j]=1;
    }
    //Debug();
}
int main()
{
    equ=var=16;
    char s[20],t[7];
    memset(s,0,sizeof(s));
    memset(t,0,sizeof(t));
    while(scanf("%s",s)!=EOF)
    {
        for(int i=0;i<3;i++)
        {
            scanf("%s",t);
            strcat(s,t);
        }
        init();
        for(int i=0;i<16;i++)
        {
            if(s[i]=='b') a[i][var]=1;
            else a[i][var]=0;
        }
        int ans1=gauss();

        init();
        for(int i=0;i<16;i++)
        {
            if(s[i]=='w') a[i][var]=1;
            else a[i][var]=0;
        }
        int ans2=gauss();

        if(ans1!=-1&&ans2!=-1)
            printf("%d\n",min(ans1,ans2));
        else if(ans1!=-1) printf("%d\n",ans1);
        else if(ans2!=-1) printf("%d\n",ans2);
        else printf("Impossible\n");
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值