hdu 4810 Wall Painting

Wall Painting

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1265    Accepted Submission(s): 360


Problem Description
Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with  different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.
 

Input
There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 10 3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.
 

Output
For each test case, output N integers in a line representing the answers(mod 10 6 +3) from the first day to the n-th day.
 

Sample Input
  
  
4 1 2 10 1
 

Sample Output
  
  
14 36 30 8
 

Source
 



题解及代码:


      拿到题目的时候一直在想有什么组合的方法,或者是DP之类的可以由两个数推导到三个数等等,想了好一会也没什么思路。

      之后想到异或的性质,因为最后的答案是要相加的,所以异或之后的每一位想要有值的话,那么我们必须保证进行异或的数字在当前位上的1个个数必须是奇数,想到这里,思路就有了。我们只需要求出每个数二进制表示形势下每一位1和0的个数,那么然后在求组合数就可以了。

     

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const long long mod=1e6+3;
long long  C[1010][1010];
long long l[70],r[70];
long long num[70];
long long sum=0;

void init()
{
    C[0][0]=1;
    C[1][0]=C[1][1]=1;C[1][2]=0;

    for(int i=2;i<=1000;i++)
    {
        C[i][0]=1;
        for(int j=1;j<=i;j++)
            C[i][j]=(C[i-1][j]+C[i-1][j-1])%mod;
        C[i][i+1]=0;
    }

    num[0]=1;num[1]=2;

    for(int i=2;i<=62;i++)
    {
       num[i]=(num[i-1]*2)%mod;
    }
}


int main()
{
    init();
    int n,color,k;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        memset(l,0,sizeof(l));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&color);
            sum+=color;
            sum%=mod;
            k=0;
            while(color)
            {
                l[k++]+=(color&1);
                color/=2;
            }
        }
        printf("%I64d",sum);
        for(int i=0;i<=62;i++)
        {
            r[i]=n-l[i];
        }
        for(int i=2;i<=n;i++)
        {
            sum=0;
            for(int j=0;j<=62;j++)
            {
                if(l[j])
                for(k=1;k<=i&&k<=l[j];k+=2)
                {
                    //printf("%d %d %d,%d %d %d,%d  \n",l[j],k,C[l[j]][k],r[j],n-k,C[r[j]][n-k],num[j]);
                   sum+=(C[l[j]][k]*C[r[j]][i-k]%mod*num[j])%mod;
                   sum%=mod;
                }
            }
            printf(" %I64d",sum);
        }
        puts("");
    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值