hdu 1198 Farm Irrigation

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map  

ADC
FJK
IHE

then the water pipes are distributed like  


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.  

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?  

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

题解:

     并查集的挺有意思的题,首先把每个图上下左右用四个数字表示,有管道的用1代表,无管道的用0代表,然后在用连个for循环遍历一遍,当一个元素的上方位是1,他的上面的元素的下方位也是1,就将他们并在一起,最后遍历一下,看看有多少个集合就行了。

代码:

#include <iostream>
#include "cstdio"
#include "stdlib.h"
using namespace std;
int m,n,i,j,root[3000],p,q;
int A[11][4]= {{1,1,0,0},{1,0,0,1},{0,1,1,0},{0,0,1,1},{1,0,1,0},{0,1,0,1},{1,1,0,1},{1,1,1,0},{0,1,1,1},{1,0,1,1},{1,1,1,1}};
int look(int a)
{
    if(root[a]!=a) root[a]=look(root[a]);
    return root[a];
}
void uni(int a,int b)
{
    a=look(a);
    b=look(b);
    if(a!=b) root[a]=b;
}


int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        char N[60][60];
        int ans=0;
        if(m==-1&&n==-1) exit(0);
        for(i=0; i<m; i++)
            scanf("%s",N[i]);

        for(i=0; i<=m*n; i++) root[i]=i;
        for(i=0; i<m; i++)
            for(j=0; j<n-1; j++)
            {
                p=int(N[i][j])-65;
                q=int(N[i][j+1])-65;
                if(A[p][3]==1&&A[q][1]==1)  uni(i*n+j+1,i*n+j+2);
            }

        for(i=0; i<m-1; i++)
            for(j=0; j<n; j++)
            {
                p=int(N[i][j])-65;
                q=int(N[i+1][j])-65;
                if(A[p][2]==1&&A[q][0]==1)  uni(i*n+j+1,(i+1)*n+j+1);
            }

        for(i=1; i<=m*n; i++)
        {

            if(root[i]==i) ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值