Dijkstra求次短路+最短路数量(好题)--poj3463

Language:
Sightseeing
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6525 Accepted: 2315

Description

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

  • M lines, each with three integers AB and L, separated by single spaces, with 1 ≤ AB ≤ NA ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to cityB with length L.

    The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

  • One line with two integers S and F, separated by a single space, with 1 ≤ SF ≤ N and S ≠ F: the starting city and the final city of the route.

    There will be at least one route from S to F.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

Sample Input

2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output

3
2

如何用Dijkstra算法求次短路及最短路和次短路的数量。

将状态扩展到二维,第一维仍然是顶点编号,第二维的长度为2,分别用于记录最短路和次短路。
这样的数据有两个,dist[][2]记录距离,cnt[][2]计数。

更新状态时:
1)新值小于最短路径长:更新最短路径长,计数;次短路径长,计数
2)新值等于最短路径长:更新最短路径计数
3)新值大于最短路径长,小于次短路径长:更新次短路径长,计数
4)新值等于次短路径长:更新次短路径计数

下面是代码:
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<cmath>
#include<climits>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
const int MAX=1010;
const int INF=1000000000;
struct node
{
    int u,v,len;
    node(){}
    node(int a,int b,int c)
    {
        u=a;
        v=b;
        len=c;
    }
};
vector<node> city[MAX];
int dis[MAX][2],cnt[MAX][2];
bool vis[MAX][2];
int pre[MAX];
int S,F;
int N,M;
int num;

void Dij()
{
    int k,temp,x;
    for(int i=0;i<=N;i++)
    {
        for(int j=0;j<2;j++)
        {
            dis[i][j]=INF;
            cnt[i][j]=0;
            vis[i][j]=0;
        }
    }
    cnt[S][0]=1;
    //vis[S]=1;
    dis[S][0]=0;
    for(int i=1;i<=2*N;i++)
    {
        int temp=INF;
        for(int j=1;j<=N;j++)
        {
            if(!vis[j][0]&&dis[j][0]<temp)
            {
                temp=dis[j][0];
                k=0;
                x=j;
            }
            else if(!vis[j][1]&&dis[j][1]<temp)
            {
                temp=dis[j][1];
                x=j;
                k=1;
            }
        }
        vis[x][k]=true;
        for(int j=0;j<city[x].size();j++)
        {
            int len=city[x][j].len;
            int v=city[x][j].v;
            if(dis[v][0]>len+temp)
            {
                dis[v][1]=dis[v][0];
                cnt[v][1]=cnt[v][0];
                dis[v][0]=len+temp;
                cnt[v][0]=cnt[x][k];
            }
            else if(dis[v][0]==len+temp)
            {
                cnt[v][0]+=cnt[x][k];
            }
            else if(dis[v][1]>len+temp)
            {
                dis[v][1]=len+temp;
                cnt[v][1]=cnt[x][k];
            }
            else if(dis[v][1]==len+temp)
                cnt[v][1]+=cnt[x][k];
        }
    }
    int ans=cnt[F][0];
    if(dis[F][0]+1==dis[F][1])
        ans+=cnt[F][1];
    cout<<ans<<endl;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    int a,b,c;
    cin>>t;
    while(t--)
    {
        cin>>N>>M;
        for(int i=0;i<=N;i++)
            city[i].clear();
        for(int i=0;i<M;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            city[a].push_back(node(a,b,c));
        }
        cin>>S>>F;
        Dij();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值