两次二分搜索--poj3685

Language:
Matrix
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 4312 Accepted: 1063

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find theM-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ M ≤ N × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939

思路:跟上一题思路差不多,先固定列,然后咱行上二分找到比答案小的个数。
下面是代码,3907ms过得,不知道大神们是怎么0ms,16ms过得。
#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
typedef long long LL;
const LL INF=10000000000;
LL N,M;
LL binary(LL i,LL x,LL y,LL d)
{
    if(x>y)
        return y;
    LL mid=(x+y)/2;
    LL p=i*i+mid*mid+100000*(mid-i)+i*mid;
    if(p<=d)
        return binary(i,mid+1,y,d);
    else
        return binary(i,x,mid-1,d);
}
bool can(LL mid)
{
    LL k=0;
    for(LL i=1;i<=N;i++)
    {
        k+=binary(i,1,N,mid);
    }
    if(k>=M)
        return true;
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>N>>M;
        LL l=-INF,r=INF,mid;
        while(r>=l)
        {
            mid=(r+l)/2;
            if(can(mid))
                r=mid-1;
            else
                l=mid+1;
        }
        cout<<l<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值