最短路--poj2387

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24926 Accepted: 8369

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.  

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.  

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N  

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:  

There are five landmarks.  

OUTPUT DETAILS:  

Bessie can get home by following trails 4, 3, 2, and 1.

最短路的一道题,Dijkstra和spfa算法都可以过,我用的是dijkstra,所以时间慢了些,还有重边要取小的:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<climits>
using namespace std;
const int big=100000000;
int cow[1010][1010];
int dis[1010];
int t,n;
void dij()
{
    bool vis[1010];
    for(int i=1; i<=n; i++)
    {
        dis[i]=cow[1][i];
        vis[i]=0;
    }
    dis[1]=0;
    vis[1]=1;
    int w;
    for(int i=2; i<=n; i++)
    {
        int min1=INT_MAX;
        for(int j=1; j<=n; j++)
            if((!vis[j])&&dis[j]<min1)
            {
                w=j;
                min1=dis[j];
            }
        vis[w]=1;
        for(int j=1; j<=n; j++)
            if((cow[j][w]!=big)&&dis[j]>dis[w]+cow[j][w])
                dis[j]=dis[w]+cow[j][w];
    }
    cout<<dis[n]<<endl;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int a,b,c;
    while(cin>>t>>n)
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(i!=j)
                    cow[i][j]=big;
                else
                    cow[i][j]=0;
        for(int i=1; i<=t; i++)
        {
            cin>>a>>b>>c;
            if(c<cow[a][b])
            cow[a][b]=cow[b][a]=c;
        }
        dij();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值