poj1700 (贪心算法)

/*
1700 - Crossing River

时间限制:	1000MS
内存限制:	10000K
问题描述

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle 
arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed;
 the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these 
 people to get across.
输入说明

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. 
The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. 
Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
输出说明

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
输入样例

1
4
1 2 5 10
输出样例

17
*/
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
bool cmp(int a,int b){
	return a<b;
}
int main(){
	//freopen("2.txt","r",stdin);
	int m,n,t[1001],i,sum=0;
	cin>>m;
	while(m--){
		cin>>n;
		for(i=0;i<n;++i){
			cin>>t[i];
		}
		sort(t,t+n);
		sum=0;
		for(i=n-1;i>2;i-=2){
			sum+=min((t[0]<<1)+t[i-1]+t[i],t[0]+(t[1]<<1)+t[i]);
		}
		if(i==2)
			sum+=t[0]+t[1]+t[2];
		else if(i==1)
			sum+=t[1];
		else
			sum+=t[0];
		cout<<sum<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值