A Funny Game

                                               1087. A Funny Game

Description
 
 
 
Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10 6) coins in a circle, as Figure 1 shows. A move consists in removing one or two  adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)

                                   

                                       Figure 1

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.) Suppose that both Alice and Bob do their best in the game.  You are to write a program to determine who will finally win the game. 

Input
There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, if Alice win the game,output "Alice", otherwise output "Bob".
Sample Input
 Copy sample input to clipboard
1
2
3
0
Sample Output
Alice
Alice
Bob
转:
        当n==1 || n==2时,明显先手必胜。
        当n==3时,明显先手必败。
        由于每次只可取1或2个,而取2个时,2个必须相邻,推断有:
        当n>3时,
        若n为偶数,先手无论如何取,后手可在先手对称的位置上取同等数量,于是先手必败。
        若n为奇数,先手取1个时,后手可在先手对称的位置上取2个,之后无论先手如何取,后手都可在先手对称的位置上取同等数量,先手必败。
                   先手一开始取2个时,可如上推出先手必败。
 
#include<iostream>
using namespace std;
int main()
{
    int num;
    while(cin>>num)
    {
    if(num==0) return 0;
    if(num<=2) cout<<"Alice"<<endl;
    else cout<<"Bob"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值