POJ - 2236 Wireless Network (并查集)

Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 14777 Accepted: 6224

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source


————————————————————————————————————————————

这题的time limit 竟然是10000MS不是1000MS。。。。

提交。。。CE。。。忘记包含cmath了。。。
第二次提交。。。。CE。。。告诉我没有pow(int, int)这种重载。。。
第三次提交。。。。CE。。。因为两次CE太郁闷了,不小心把第二个pow函数写成double(pow(……))了。。。。
第四次。。。终于AC了。。。

好“机智”的vs2012。。。。自动帮我包含了。。。下次要一定记得在用之前先include!!

数据结构: 并查集

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
#define MAX 1010
struct P
{
	int x, y;
}p[MAX];
int N, D, ok[MAX];

inline bool in(int a, int b){return  pow(double(p[a].x-p[b].x), 2)+ pow(double(p[a].y-p[b].y), 2) <= D*D;}

//并查集
int par[MAX], rak[MAX];
void init(int n)
{
	for(int i = 1; i <= n; i++)
	{
		par[i] = i;
		rak[i] = 0;
	}
}
int find(int x) { return par[x] == x ? x : par[x] = find(par[x]);}
void unite(int a, int b)
{
	a = find(a); b = find(b);
	if(a == b)	return ;
	if(rak[a] < rak[b])
		par[a] = b;
	else
	{
		par[b] = a;
		if(rak[a] == rak[b])
			rak[a]++;
	}
}
int same(int a, int b) { return find(a) == find(b); }
int main()
{
	//freopen("in.txt","r",stdin);  
	scanf("%d%d", &N, &D);
	for(int i = 1; i <= N; i++)
		scanf("%d%d", &p[i].x, &p[i].y);

	init(N);
	char s[10];
	while(scanf("%s", s) != EOF)
	{
		if(*s == 'O')
		{
			int c;
			scanf("%d", &c);
			ok[c] = 1;
			for(int i = 1; i <= N; i++)
				if(i != c && ok[i] && !same(i, c) && in(i, c))
					unite(i, c);
		}
		else
		{
			int x, y;
			scanf("%d%d", &x, &y);
			printf(same(x, y) ? "SUCCESS\n" : "FAIL\n");
		}
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值