hdu 4902 Nice boat 2014年多校联合第四场

43 篇文章 0 订阅


点击打开题目链接

Nice boat

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 49    Accepted Submission(s): 17


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. 

One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died.

Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest.

There is a hard data structure problem in the contest:

There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2).

You should output the final sequence.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n separated by a single space.
The next line contains an integer Q, denoting the number of the operations.
The next Q line contains 4 integers t,l,r,x. t denotes the operation type.

T<=2,n,Q<=100000
a_i,x >=0
a_i,x is in the range of int32(C++)
 

Output
For each test case, output a line with n integers separated by a single space representing the final sequence.
Please output a single more space after end of the sequence
 

Sample Input
  
  
1 10 16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709 10 1 3 6 74243042 2 4 8 16531729 1 3 4 1474833169 2 1 8 1131570933 2 7 9 1505795335 2 3 7 101929267 1 4 10 1624379149 2 2 8 2110010672 2 6 7 156091745 1 2 5 937186357
 

Sample Output
  
  
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149
 

Author
WJMZBMR
 

Source
题意:

给出一个数组,有两种类型的操作,类型一:将所有数都换成x;类型二:将所有大于x的数都换成gcd(a[i],x);

求操作完之后的数组,并输出。

数据很水,简单优化一下,暴力过。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#define maxn 100010
using namespace std;
typedef long long ll;
int a[maxn];
struct point
{
    int op,l,r,x;
}p[maxn];
int GCD(int a,int b)
{
    if(!b)
        return a;
    else
        return GCD(b,a%b);
}
int main()
{
 int T;
 int n,m;
 int visit[maxn];
scanf("%d",&T);
 while(T--)
 {
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    scanf("%d",&m);
   for(int i=1;i<=m;i++)
    scanf("%d%d%d%d",&p[i].op,&p[i].l,&p[i].r,&p[i].x);
    memset(visit,-1,sizeof(visit));
    for(int j=m;j>0;j--)
    {
    if(p[j].op==1)
    {
        for(int i=p[j].l;i<=p[j].r;i++)
            if(visit[i]==-1)
           {
               visit[i]=maxn;
               a[i]=p[j].x;
           }
           else
            if(visit[i]==0)
           {
               visit[i]=j+1;
               a[i]=p[j].x;
           }
        }
    else
    if(p[j].op==2)
    {
        for(int i=p[j].l;i<=p[j].r;i++)
           if(visit[i]==-1)
                visit[i]=0;
        }
    }
    for(int i=1;i<=n;i++)
    {
        if(visit[i]==maxn||visit[i]==-1)
            continue;
        else
            for(int j=visit[i];j<=m;j++)
                if(a[i]>p[j].x&&p[j].l<=i&&p[j].r>=i)
                    a[i]=GCD(a[i],p[j].x);
    }

    for(int i=1;i<=n;i++)
            printf("%d ",a[i]);


        printf("\n");
 }
 return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值