UVA 10026 Shoemaker's Problem (贪心)

 Shoemaker's Problem 

Shoemaker has N jobs (orders from customers) which he must make. Shoemaker can work on only one job in each day. For each ith job, it is known the integer Ti (1<=Ti<=1000), the time in days it takes the shoemaker to finish the job. For each day of delay before starting to work for the ith job, shoemaker must pay a fine of Si (1<=Si<=10000) cents. Your task is to help the shoemaker, writing a programm to find the sequence of jobs with minimal total fine.

The Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

First line of input contains an integer N (1<=N<=1000). The next N lines each contain two numbers: the time and fine of each task in order.

The Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

You programm should print the sequence of jobs with minimal fine. Each job should be represented by its number in input. All integers should be placed on only one output line and separated by one space. If multiple solutions are possible, print the first lexicographically.

Sample Input

1

4
3 4
1 1000
2 2
5 5

Sample Output

2 1 3 4

题意:鞋匠有n个任务。每个任务有一个完成所需时间day。和每过一天要陪的钱数value。。要求一个顺序使得赔钱最少。

思路:很明显要用贪心。。贪心的策略是第i,j个任务,如果valuei * dayj > vauej * dayi,说明先修j赔款大于先修i,所以应该先修i。。所以只要把序列按这个策略排序即可。。

这里有一个注意点。。就是要输出的是字典序最小的 所以在排序的时候如果相同。那么就按任务编号从小到大排序即可。。

代码:

#include <stdio.h>
#include <algorithm>
using namespace std;

int t, n;
struct Shose {
    int day;
    int value;
    int num;
} s[1005];

int cmp(Shose a, Shose b) {
    if (a.value * b.day != b.value * a.day)
	return a.value * b.day > b.value * a.day;
    return a.num < b.num;
}
int main() {
    scanf("%d", &t);
    while (t --) {
	scanf("%d", &n);
	for (int i = 1; i <= n; i ++) {
	    scanf("%d%d", &s[i].day, &s[i].value);
	    s[i].num = i;
	}
	sort(s + 1, s + n + 1, cmp);
	for (int i = 1; i < n; i ++)
	    printf("%d ", s[i].num);
	printf("%d\n", s[n].num);
	if (t) printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值