POJ 1269 Intersecting Lines(几何 + 直线问题)

Intersecting Lines
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9049 Accepted: 4059

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题意:给定4个点,前两个点组成一条直线,后两个点组成另一条直线。要判断两直线是相交,还是重合,还是共线。如果是相交还要输出交点。

思路:直线方程我们知道是 y = k*x + b. k和b都相同的共线。k相同,b不相同的重合。k不同的相交。这样就很好解决了。

k = (y2 - y1)/(x2 - x1)。 b = y - k * x; 然后求交点的时候, x = (b1 - b2)/(k2 - k1). y = k * x + b。不过要注意,斜率k不存在的情况要特殊考虑。还有double型判断相等不能直接==,会有精度误差。

代码:

#include <stdio.h>
#include <math.h>
#include <stdlib.h>
int n, i, l;
struct Point {
	double x, y;
} p[4];

double k[2], b[2];
int main() {
	while (~scanf("%d", &n)) {
		printf("INTERSECTING LINES OUTPUT\n");
		for (l = 0; l < n; l ++) {
			for (i = 0; i < 4; i ++) {
				scanf("%lf%lf", &p[i].x, &p[i].y);
			}
			if (p[1].x == p[0].x)//斜率不存在
				k[0] = 2000000000;
			else
				k[0] = (p[1].y - p[0].y) / (p[1].x - p[0].x);
			if (p[3].x == p[2].x)
				k[1] = 2000000000;
			else
				k[1] = (p[3].y - p[2].y) / (p[3].x - p[2].x);
			if (k[0] == 2000000000) 
				b[0] = p[0].x;
			else
				b[0] = p[0].y - k[0] * p[0].x;
			if (k[1] == 2000000000)
				b[1] = p[2].x;
			else
				b[1] = p[2].y - k[1] * p[2].x;
			if (fabs(k[0] - k[1]) < 10e-9 && fabs(b[0] - b[1]) < 10e-9)
				printf("LINE\n");
			else if (fabs(k[0] - k[1]) < 10e-9 && fabs(b[0] - b[1]) >= 10e-9)
				printf("NONE\n");
			else {
				printf("POINT");
				double xx, yy;
				if (k[0] == 2000000000) {
					xx = p[0].x;
					yy = k[1] * p[0].x + b[1];
				}
				else if (k[1] == 2000000000) {
					xx = p[2].x;
					yy = k[0] * p[2].x + b[0];
				}
				else {
					xx = (b[0] - b[1]) / (k[1] - k[0]);
					yy = k[0] * xx + b[0];
				}
				printf(" %.2lf %.2lf\n", xx, yy);
			}
		}
		printf("END OF OUTPUT\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值