UVALive 2949 Elevator Stopping Plan(二分 + 贪心)

ZSoft Corp. is a software company in GaoKe Hall. And the workers in the hall are very hard-working. But the elevator in that hall always drives them crazy. Why? Because there is only one elevator in GaoKe Hall, while there are hundreds of companies in it. Every morning, people must waste a lot of time waiting for the elevator.

Hal, a smart guy in ZSoft, wants to change this situation. He wants to find a way to make the elevator work more effectively. But it's not an easy job.


There are 31 floors in GaoKe Hall. It takes 4 seconds for the elevator to raise one floor. It means:

It costs (31 - 1)×4 = 120 seconds if the elevator goes from the 1-st floor to the 31-st floor without stop. And the elevator stops 10 second once. So, if the elevator stops at each floor, it will cost 30×4 + 29×10 = 410 seconds (It is not necessary to calculate the stopping time at 31st floor). In another way, it takes 20 seconds for the workers to go up or down one floor. It takes 30×20 = 600 seconds for them to walk from the 1-st floor to the 31-st floor. Obviously, it is not a good idea. So some people choose to use the elevator to get a floor which is the nearest to their office.


After thinking over for a long time, Hal finally found a way to improve this situation. He told the elevator man his idea: First, the elevator man asks the people which floors they want to go. He will then design a stopping plan which minimize the time the last person need to arrive the floor where his office locates. For example, if the elevator is required to stop at the 4-th, 5-th and 10-th floor, the stopping plan would be: the elevator stops at 4-th and 10-th floor. Because the elevator will arrive 4th floor at 3×4 = 12 second, then it will stop 10 seconds, then it will arrive 10th floor at 3×4 + 10 + 6×4 = 46 second. People who want to go 4-th floor will reach their office at 12 second, people who want to go to 5-th floor will reach at 12 + 20 = 32 second and people who want to go to 10-th floor will reach at 46 second. Therefore it takes 46 seconds for the last person to reach his office. It is a good deal for all people.

Now, you are supposed to write a program to help the elevator man to design the stopping plan, which minimize the time the last person needs to arrive at his floor.

Input 

The input consists of several testcases. Each testcase is in a single line as the following:

n f 1  f 2 ...  f n

It means, there are totally n floors at which the elevator need to stop, and n = 0 means no testcases any more. f1 f2 ... fn are the floors at which the elevator is to be stopped (n$ \le$302$ \le$f1 < f2 < ... < fn$ \le$31). Every number is separated by a single space.

Output 

For each testcase, output the time the last reading person needs in the first line and the stopping floors in the second line. Please note that there is a summary of the floors at the head of the second line. There may be several solutions, any appropriate one is accepted. No extra spaces are allowed.

Sample Input 

3 4 5 10
1 2
0

Sample Output 

46
2 4 10
4
1 2
题意:一个公司只有一台电梯,现在有n个人,他们分别有一个想到的楼层,如果坐电梯4秒一层,但是停电梯要花费10秒,如果走路要20秒一层。问如何保证最后一个人到达目的楼层时间最小。

思路:贪心 + 二分,二分时间,知道一个最小的时间满足所有人都能到相应楼层。在二分的过程中利用贪心来判断每个人是否能到相应楼层。我们知道在限定时间内,如果电梯在那个人的当前楼层停下,那个人所要花费的时间是最短的。如果不能满足这个条件,这个限定时间即为不合理。如果能满足条件,我们在考虑,尽量让电梯往高了去开门,因为这样的话,能满足更多人的需求。因为往高了去开门在走下楼,如果当前这个人满足了。之后几个层数的人时间肯定不会比这个人大,肯定都是满足的。这样可以在限定时间内让更多人到达相应楼层。利用这样的策略,求得最终解。并且保存下开门的层数以便输出。

代码:

#include <stdio.h>
#include <string.h>

int n, vis[35], i, sb, top, start, end, mid, open[35], num;

void init() {
	top = 1; 
	memset(vis, 0, sizeof(vis));
	for (i = 0; i < n; i ++) {
		scanf("%d", &sb);
		vis[sb] = 1;
		if (sb > top)
			top = sb;
	}
	start = 0; 
	end = 14 * (top - 1);
}

int judge(int t) {
	int i, j;
	num = 0;
	i = t / 20 + 2;
	while (i <= top) {
		while (i <= top && !vis[i])
			i ++;
		if (4 * (i - 1) + 10 * num > t) 
			return 0;
		j = (t - 10 * num + 20 * i + 4) / 24;
		i = (t - 10 * num + 16 * j + 4) / 20 + 1;
		open[num ++] = j;
	}
	return 1;
}

int solve() {
	while (start < end - 1) {
		mid = (start + end) / 2;
		if (judge(mid))
			end = mid;
		else
			start = mid;
	}
	return end;
}
int main() {
	while (~scanf("%d", &n) && n) {
		init();
		printf("%d\n", solve());
		judge(end);
		printf("%d", num);
		for (i = 0; i < num; i ++)
			printf(" %d", open[i]);
		printf("\n");
	}
	return 0;
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REaDME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值