UVA 10271 Chopsticks(dp)

Problem C
Chopsticks
Input:
Standard Input
Output: Standard Output

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)2 is called the 'badness' of the set.

It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.

Input

The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).

Output

For each test case in the input, print a line containing the minimal total badness of all the sets.

Sample Input

1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output

23

Note

For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160a

题意:给定n个小伙伴和m只筷子。要把这些筷子每3根一组分成n + 8 组给小伙伴,并且要满足3根筷子长度x, y ,z使得:x <= y <= z 代价为(x - y)^2, 要求最小代价分得满足条件。

思路:dp,i表示分成几组, j表示使用前j双筷子。要先把序列从大到小排序。这样的话就一定满足x <= y <= z 。

状态转移方程为:dp[i][j] = min{dp[i][j - 1], dp[i - 1][j - 2] + w,w为组j和j - 1的代价。

代码:

#include <stdio.h>
#include <string.h>
#include <limits.h>
#include <algorithm>
using namespace std;

int cmp(int a, int b) {
	return a > b;
}

int min(int a, int b) {
	return a < b ? a : b;
}

int t, n, m, ch[5005], dp[1005][5005], i, j, num[5005];

void init() {
	scanf("%d%d", &n, &m);
	n += 8;
	for (i = 1; i <= m; i ++) {
		scanf("%d", &ch[i]);
	}
	sort(ch + 1, ch + m + 1, cmp);
	memset(dp, 0, sizeof(dp));
	for (i = 1; i <= n; i ++) {
		for (j = 1; j <= m; j ++) {
			dp[i][j] = 999999999;
		}
	}
	for (i = 1; i <= m; i ++) {
		num[i] = (ch[i - 1] - ch[i]) * (ch[i - 1] - ch[i]);
	}
}

int main() {
	scanf("%d", &t);
	while (t --) {
		init();
		for (i = 1; i <= n; i ++) {
			for (j = i * 3; j <= m -(n - i) * 2; j ++) {
				dp[i][j] = min(dp[i][j - 1], dp[i - 1][j - 2] + num[j]);
			}
		}
		printf("%d\n", dp[n][m]);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值