UVA 585 - Triangles(枚举)

  Triangles 

It is always very nice to have little brothers or sisters. You can tease them, lock them in the bathroom or put red hot chili in their sandwiches. But there is also a time when all meanness comes back!


As you know, in one month it is Christmas and this year you are honored to make the big star that will be stuck on the top of the Christmas tree. But when you get the triangle-patterned silver paper you realize that there are many holes in it. Your little sister has already cut out smaller triangles for the normal Christmas stars. Your only chance is to find an algorithm that tells you for each piece of silver paper the size of the largest remaining triangle.


Given a triangle structure with white and black fields inside you must find the largest triangle area of white fields, as shown in the following figure.

Input 

The input file contains several triangle descriptions. The first line of each description contains an integer  n  (  $1 \leŸ n \leŸ 100$ ), which gives the height of the triangle. The next  n  lines contain characters of the set { space # - } representing the rows of the triangle, where ` # ' is a black and ` - ' a white field. The spaces are used only to keep the triangle shape in the input by padding at the left end of the lines. (Compare with the sample input. The first test case corresponds to the figure.)

For each triangle, the number of the characters `#' and `-' per line is odd and decreases from 2n - 1 down to 1.


The input is terminated by a description starting with n = 0.

Output 

For each triangle in the input, first output the number of the triangle, as shown in the sample output. Then print the line `` The largest triangle area is  a .'', where  a  is the number of fields inside the largest triangle that consists only of white fields. Note that the largest triangle can have its point at the top, as in the second case of the sample input.


Output a blank line after each test case.

Sample Input 

5
#-##----#
 -----#-
  ---#-
   -#-
    -
4
#-#-#--
 #---#
  ##-
   -
0

Sample Output 

Triangle #1
The largest triangle area is 9.

Triangle #2
The largest triangle area is 4.

题意:求出给定三角形中最大-三角形。

思路:暴力枚举。

代码:

#include <stdio.h>
#include <string.h>
#define min(a,b) (a)<(b)?(a):(b)
#define max(a,b) (a)>(b)?(a):(b)
#define INF 0x3f3f3f3f
const int N = 205;

int n, g[N][N];

void init() {
	char str[N];
	memset(g, 0, sizeof(g));
	for (int i = 0; i < n; i ++) {
		scanf("%s", str);
		for (int j = i; j < strlen(str) + i; j ++) {
			if (str[j - i] == '-') g[i][j] = 1;
		}
	}
}

bool judge(int x, int y, int d) {
	if (x < 0 || x >= n) return false;
	for (int i = y; i < 2 * d + 1 + y; i ++) {
		if (!g[x][i] || y < 0 || y >= 2 * n - 1)
			return false;
	}
	return true;
}

int dfs(int x, int y, int d, int D) {
	if (!judge(x, y, d)) return 0;
	return dfs(x + D, y - 1, d + 1, D) + 2 * d + 1;
}

int solve() {
	int ans = 0;
	for (int i = 0; i < n; i++)
		for (int j = i; j < 2 * n - 1 - i; j++) {
			if (g[i][j]) {
				if ((j - i) % 2) {
					ans = max(ans, dfs(i, j, 0, 1));
				}
				else {
					ans = max(ans, dfs(i, j, 0, -1));
				}
			}
		}
	return ans;
}

int main() {
	int cas = 0;
	while (~scanf("%d", &n) && n) {
		init();
		printf("Triangle #%d\nThe largest triangle area is %d.\n\n", ++cas, solve());
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值