UVA 1419 - Ugly Windows(搜索,模拟)

Sheryl works for a software company in the country of Brada. Her job is to develop a Windows operating system. People in Brada are incredibly conservative. They even never use graphical monitors! So Sheryl's operating system has to run in text mode and windows in that system are formed by characters. Sheryl decides that every window has an ID which is a capital English letter (`A' to `Z'). Because every window had a unique ID, there can't be more than 26 windows at the same time. And as you know, all windows are rectangular.

On the screen of that ugly Windows system, a window's frame is formed by its ID letters. Fig-1 shows that there is only one window on the screen, and that window's ID is `A'. Windows may overlap. Fig-2 shows the situation that window B is on the top of window A. And Fig-3 gives a more complicated overlapping. Of course, if some parts of a window are covered by other windows, you can't see those parts on the screen.


.........................
....AAAAAAAAAAAAA........
....A...........A........
....A...........A........
....A...........A........
....AAAAAAAAAAAAA........
.........................


Fig-1


.........................
....AAAAAAAAAAAAA........
....A...........A........
....A.......BBBBBBBBBB...
....A.......B........B...
....AAAAAAAAB........B...
............BBBBBBBBBB...
.........................


Fig-2


..........................
....AAAAAAAAAAAAA.........
....A...........A.........
....A.......BBBBBBBBBB....
....A.......B........BCCC.
....AAAAAAAAB........B..C.
.......C....BBBBBBBBBB..C.
.......CCCCCCCCCCCCCCCCCC.
..........................


Fig-3


If a window has no parts covered by other windows, we call it a ``top window" (The frame is also considered as a part of a window). Usually, the top windows are the windows that interact with user most frequently. Assigning top windows more CPU time and higher priority will result in better user experiences. Given the screen presented as Figs above, can you tell Sheryl which windows are top windows?

Input 

The input contains several test cases.

Each test case begins with two integers, n and m (1$ \le$nm$ \le$100) , indicating that the screen has n lines, and each line consists of m characters.

The following n lines describe the whole screen you see. Each line contains m characters. For characters which are not on any window frame, we just replace them with `.' .

The input ends with a line of two zeros.


It is guaranteed that:

1)
There is at least one window on the screen.
2)
Any window's frame is at least 3 characters wide and 3 characters high.
3)
No part of any window is outside the screen.

Output 

For each test case, output the IDs of all top windows in a line without blanks and in alphabet order.

Sample Input 

9 26 
..........................
....AAAAAAAAAAAAA.........
....A...........A.........
....A.......BBBBBBBBBB....
....A.......B........BCCC.
....AAAAAAAAB........B..C.
.......C....BBBBBBBBBB..C.
.......CCCCCCCCCCCCCCCCCC.
..........................
7 25
.........................
....DDDDDDDDDDDDD........
....D...........D........
....D...........D........
....D...........D..AAA...
....DDDDDDDDDDDDD..A.A...
...................AAA... 
0 0

Sample Output 

B 
AD

题意很好理解吧,找出最前的窗口。

思路:先找框框,找到框框之后判断框框内部是不是都是'.',如果是就是最前的窗口。

代码:

#include <stdio.h>
#include <string.h>
#include <map>
#include <algorithm>
using namespace std;
const int N = 105;

int n, m, xp[4], yp[4];
char g[N][N], ans[N * N];;
map<char, int> vis;

void init() {
	vis.clear();
	for (int i = 0; i < n; i ++)
		scanf("%s", &g[i]);
}

bool judge(int sx, int sy, int x, int y, char c) {
	xp[0] = x + 1; yp[0] = y + 1;
	while (y + 1 < m && g[x][y + 1] == c) {
		y++;
	}
	xp[1] = x + 1; yp[1] = y - 1;
	while (x + 1 < n && g[x + 1][y] == c) {
		x++;
	}
	xp[2] = x - 1; yp[2] = y - 1;
	while (y - 1 >= 0 && g[x][y - 1] == c) {
		y--;
	}
	xp[3] = x - 1; yp[3] = y + 1;
	while (x - 1 >= 0 && g[x - 1][y] == c) {
		x--;
		if (x == sx && y == sy)
			return true;
	}
	return false;
}

bool isOK() {
	for (int i = xp[0]; i <= xp[3]; i++)
		for (int j = yp[0]; j <= yp[1]; j++)
			if (g[i][j] != '.')
				return false;
	return true;
}

void solve() {
	int ansn = 0;
	memset(ans, 0, sizeof(ans));
	for (int i = 0; i < n; i++)
		for (int j = 0; j < m; j++) {
			if (g[i][j] == '.' || vis[g[i][j]]) continue;
			vis[g[i][j]] = 1;
			if (judge(i, j, i, j, g[i][j])) {
				if (isOK())
					ans[ansn++] = g[i][j];
			}
		}
	sort(ans, ans + ansn);
	printf("%s\n", ans);
}

int main() {
	while (~scanf("%d%d", &n, &m) && n + m) {
		init();
		solve();
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值