ZOJ 3197 (贪心)

Google Book

Time Limit: 1 Second       Memory Limit: 32768 KB

You, the best hacker in the world, want to download the books published on Google Book. After some investigation, you found that the address of each page consists of two parts. The first part is the page number, the second part is the signature which is unique for each page. To get the signature, you can send the query to the server. The query has one parameter, which indicates the page number. The server will return the signature of the required page, and it may also return the signature of some adjacent pages.

To minimize the bytes downloaded from the internet, and also make the server adminstrator hard to notice your "hack", you'd like to minimize the number of queries

Input

The input has multiple cases.
The first line of the input is a single integer T which is the number of test cases. Then T consecutive test cases follow. In each test case, the first line is a number N (1<=N<=5000), indicating the number of pages of the book. Then n lines follows. On the i-th line, there will be two integers ai and bi (ai<=i<=bi). They indicate that the query for the i-th page will return the signatures from page ai to page bi (inclusive)

Output

Results should be directed to standard output. The output of each test case should be a single integer, which is the minimum number of queries to get all the signatures.

Sample Input

2
3
1 1
2 2
3 3
3
1 1
1 3
3 3

Sample Output

3
1

题意:给定n种翻书方式(每次翻书方式为第ai页到bi页)。。要求最少翻书数翻完整本书

思路:贪心。先进行排序。按bi从大到小排序。然后从第一页开始翻。这样保证了每次都翻到能翻到的最大页数。所以次数是最少的。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int t;
int n;
int num;
int vis[5005];
struct C {
    int start;
    int end;
} ci[5005];

int cmp(C a, C b) {
    return a.end > b.end;
}

int main() {
    scanf("%d", &t);
    while (t --) {
	memset(vis, 0, sizeof(vis));
	memset(ci, 0, sizeof(ci));
	num = 0;
	scanf("%d", &n);
	for (int i = 0; i < n; i ++)
	    scanf("%d%d", &ci[i].start, &ci[i].end);
	sort(ci, ci + n, cmp);
	int tt = 1;
	while (tt <= n) {
	    for (int i = 0; i < n; i ++) {
		if (!vis[i] && ci[i].start <= tt) {
		    vis[i] = 1;
		    tt = ci[i].end + 1;
		    num ++;
		    break;
		}
	    }
	}
	printf("%d\n", num);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值