hdu 题目1754 I Hate It (线段树,区间最大值)

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27989    Accepted Submission(s): 11104


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 


 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 


 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 


 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 


 

Sample Output
  
  
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin

 

 

记录区间最值,注意3中方向,向左子树,向右子树,分开两边的

 

 

/********************** 
2013-8-19 18:35:49  
Time: 500MS  Memory: 7180K 
Author: zyh
Status: Accepted
**********************/ 
#define N 200010
#define MAX(a,b) (a)>(b)?(a):(b)
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>

using namespace std;

struct IntervalTree{
	int L,R,max;
}tree[N*3];

int aa[N];

void build(int p,int l,int r){
	
	tree[p].L = l; tree[p].R = r;

	if(l==r) {
		tree[p].max = aa[l];
		return ;
	}
	int mid = (l+r)>>1;
	
	build(p<<1,l,mid);
	build(p<<1|1,mid+1,r);

	tree[p].max = MAX(tree[p<<1].max,tree[p<<1|1].max);
}


void change(int p,int a,int b){
	
	if(tree[p].L ==a &&  tree[p].R==a ){
		tree[p].max = b;
		return;
	}
	if(a<tree[p<<1|1].L)	change(p<<1,a,b);
	else	change(p<<1|1,a,b);
	tree[p].max = MAX(tree[p<<1].max,tree[p<<1|1].max); 
}

int query(int p,int l,int r){
	
	if( l == tree[p].L && r == tree[p].R )	return tree[p].max;

	int mid = (tree[p].L + tree[p].R)>>1;
	if(r<=mid)	return query(p<<1,l,r);
	else if(l>mid)	return query(p<<1|1,l,r);
	else{
		int tmp1 = query(p<<1,l,mid); // 这里不能直接放在宏定义函数中,不然超时 
		int tmp2 = query(p<<1|1,mid+1,r);	
		return MAX(tmp1,tmp2);
	}	
	
}


int main()
{
	int n,m,i,a,b;
	char s[2];
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;i++) scanf("%d",&aa[i]);
		build(1,1,n);
	
		while(m--){
			scanf("%s",s);
			if(s[0]=='Q'){
				scanf("%d%d",&a,&b);
				printf("%d\n",query(1,a,b));
			}
			else{
				scanf("%d%d",&a,&b);
				change(1,a,b);	
			}
		}
	}
	return 0;
} 


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值