A - Hunters题解

                                                                          A - Hunters

Time Limit:1000MS     Memory Limit:32768KB     64bitIO Format:%I64d & %I64u

Description

Alice and Bob are the topmost hunters in the forest, so no preys canescape from them. However, they both think that its hunting skill is betterthan the other. So they need a match.
In their match, the targets are two animals, a tiger and a wolf. They both knowthat the tiger is living in the south of the forest and the wolf is living inthe north of the forest. They decide that the one who kills the tiger scores Xpoints and who kills the wolf scores Y points. If the one who kills both tigerand wolf scores X+Y points.
Before the match starts, Aliceis in the east of the forest and Bob is in the west of the forest. When thematch starts, Alice and Bob will choose one of the preys as targets. Becausethey haven't known the other's choice, maybe they choose the same target. Therewill be two situations:
(1) If they choose different targets, they both are sure of killing theirrespective targets.
(2) If they choose the same target, the probability of Alice killing the target is P, and theprobability of Bob killing it is 1-P. Then they will hunt for the other prey,also the probability of Alicekilling it is P and the probability of Bob killing it is 1-P.
But Alice knowsabout Bob. She knows that the probability of Bob choosing tiger as his firsttarget is Q, and the probability of choosing wolf is 1-Q. So that Alice can decide herfirst target to make her expected score as high as possible.

 

Input

The first line of input contains an integer T (1≤T≤10000), the numberof test cases.
Then T test cases follow. Each test case contains X, Y, P, Q in one line. X andY are integers and 1≤X, Y≤1000000000. P and Q are decimals and 0≤P, Q≤1, andthere are at most two digits after decimal point.

 

Output

For each test case, output the target Alice should choose and the highest expectedscore she can get, in one line, separated by a space. The expected score shouldbe rounded to the fourth digit after decimal point. It is guaranteed that Alice will have differentexpected score between choosing tiger and wolf.

 

Sample Input

3

2 1 0.5 0.5

2 1 0 1

7 7 0.32 0.16

 

Sample Output

tiger 1.7500

wolf 1.0000

tiger 6.5968


      这是求期望值的简单数学题。代码如下:

#include"stdio.h"
int main()
{
	int T;
	int x,y;
	double p,q,d1,d2;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%lf%lf",&x,&y,&p,&q);
		d1=(1-q)*x+p*q*(x+y);
		d2=(1-q)*p*(x+y)+q*y;
		if(d1>d2)
		{
			printf("tiger %.4lf\n",d1);
		}
		else
		{
			printf("wolf %.4lf\n",d2);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值