uva 540 Team Queue(队列+模拟)

737 篇文章 0 订阅

  Team Queue 

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.


In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.


Your task is to write a program that simulates such a team queue.

Input 

The input file will contain one or more test cases. Each test case begins with the number of teams  t  (  $1 \le t \le 1000$ ). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

  • ENQUEUE x - enter element x into the team queue
  • DEQUEUE - process the first element and remove it from the queue
  • STOP - end of test case

The input will be terminated by a value of 0 for t.


Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output 

For each test case, first print a line saying `` Scenario # k ", where  k  is the number of the test case. Then, for each  DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input 

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output 

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

题目大意:有n组人排队,输入n行,每行第一个数字代表该组所有的人数的序号。然后输入命令ENQUEUE代表入队,如果前面的队伍中有和自己同一组的,要直接插在同组人的后面,否则放在队末。DEQUEUE代表出队,站在第一个的要离开队伍。STOP中指命令。按顺序输出出队人的序号。

解题思路:模拟的方法。用queue的数组模拟排队的情况。

#include<iostream>
#include<string.h>
#include<queue>
using namespace std;

#define N 1000005
#define M 1005 

int p[N];
int now[N];
int cnt_now;
int sex[M];

int main()
{
	int t = 1;
	int n;
	
	while(cin >> n, n) 
	{
		// Init.
		memset(p, 0, sizeof(p));
		memset(now, 0, sizeof(now));
		memset(sex, 0, sizeof(sex));
		cnt_now = 0;

		// Read.
		    for(int i = 1; i <= n; i++) { int sum;
			cin >> sum;
			for(int j = 0; j < sum; j++)
			{
				int f;
				cin >> f;
				p[f] = i;
			}
		}

		int first = 0;
		queue<int> team[M];
		char str[10];
		int num;
		int move;

		while(cin >> str)
		{
			if( strcmp( str, "STOP") == 0) 
				break; 
			else if( strcmp( str, "DEQUEUE" ) == 0) 
			{
				now[cnt_now++] = team[first].front();
				team[first].pop();

				if(team[first].empty())
				{
					sex[first] = 0;
					first++;	
				}
			}
			else
			{
				if(first >= M)
					first = first % M;

				cin >> num;
				for(move = first; ; move++)
				{
					if(move >= M )
						move = move % M;

					if(sex[move] == p[num])
						break;
					else if(sex[move] == 0)
						break;
				}	
				team[move].push(num);
				sex[move] = p[num];
			} 
		}

		cout <<"Scenario #" << t++ << endl;
		for(int i = 0; i < cnt_now; i++)
			cout << now[i] << endl;
		cout << endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值